HT801 Cannot upgrade firmware


current info: Program – Bootloader – Core – Base –

I have tried to update via http at

I have tried to use local http server as well as a local tftp server, no sucess. Cannot use the web interface to update either, as file size is too big it says. All the right boxes are checked, but upon a reboot, it just says Provision: Not running, Last status : Downloading file from url.

I have 2 units, brand new that I cannot upgrade the firmware to work with 3CX right now.

Please advise.

No idea how to use wireshark to capture what the ATA is doing after a reboot.


try to make a format factory first


Is that under " Basic, Reset type, Full Reset?"

If so, I have tried that.





Try factory reset.


says he did :slight_smile:


i got the same problem


It ended up working for me after I put the grandstream firmware link in and left it for hours after rebooting. Came back and it was updated.


You can push upgrade via ssh/telnet.


Hi there. I have 2 brand new HT801 and HT802 units for a job. I get the same HTTP 500 failures when trying to upgrade manually, and it’s not upgrading via HTTP download from the firmware site or va TFTP from my own server which I use for all my other VoIP phones. I’ve also tried going in via SSH and issuing the command to upgrade via TFTP and HTTP and that doesn’t work either. I’ve worked on a few of these HT800’s over the past few years and NEVER successfully updated the firmware on one. Very frustrating units.


I was trying to update my HT812 and had the same problem. From the release notes:

GRANDSTREAM NETWORKS HT801/802/812/814/818 Firmware Release Notes Page 1
HT801/802/812/814/818 Firmware Release Notes
• The previous release notes can be downloaded here:
• If HT8xx firmware version is equal or older than in, users cannot use web UI
option “Upload from Local Directory” to upload a firmware file equal to or newer than Please configure web UI option “Firmware Upgrade and Provisioning” to set
a valid method for the device to obtain firmware via TFTP/HTTP/HTTPS over the
network. Please see section “Upgrading and Provisioning” in HT80X Administration
Guide, HT81X Administration Guide, and HT818 Administration Guide for details


ADVANCED SETTINGS >> Firmware Server Path:

ok then restart HT812, and wait


I’m guessing that it replaces “” as the default?


yes, then restart HT812


How long is the firmware update supposed to take? I rebooted 20 mins ago and it’s still flashing.

Selected as the firmware server path with HTTP.

Also, if the update is actually stuck how can I recover my device? Can I just unplug the power and replug it back in?


if the device crashes, try doing a format factory,
keep in mind that if you block the FW installation halfway, you may find the product unusable.