HT503 HT502 peer to peer problem


#1

Hello,
i ve set up the peer to peer between HT503 and HT502 according to http://www.grandstream.com/sites/default/files/Resources/peer_to_peer_HT502-HT-503_0.pdf
I can receive calls. And most of the times i can make calls to. But sometime when i try to make a phone call i get a busy tone. I see the yellow light (phone1) of the HT502 but the line light on HT503 does not light up. It seems that there is some problem with the hook off auto dial, or some communication problem between the 502 and 503. Both of them are in the same LAN (still testing).
Is this normal? Any suggestions?
Thanks in advance


#2

I have been trying the same thing with similar results. I can receive calls from the FXO, but can make a call (From the HT502 FXS) EXCEPT within the first 10 seconds or so of a 502 reboot. After that time, the 502 does not seem to contact the 503 at all.

I am starting to believe my problem is related to some embedded and unknown Service Provider config (that a “factory restore” does not remove), as I bought the 502 used.

EDIT ABOVE: Tried another HT502 and it worked fine.


#3

I wish this was the case but I did flash both the 502 and 503 with the latest firmware. I don’t think any of the settings we’re kept. I had the same problem before and after flashing them


#4

There are two threads related to the same subject, so I will only post on this one.

I have set up a simulation of the scenario in my lab, Unfortunately, I do not have any POTS lines, but I do have a Viking line simulator, so while not exactly the same, the results of getting the HTs to communicate and function between one another should be the same.

However, there is one huge caveat that needs to be pointed out.The HT503 going off-hook is highly dependent on the POTs line condition. I have about 30 of these being used as life-line 911 interfaces in hotels across the country. They work well, but I have run into situations where the loop current was not enough and as a result, the HT was not able to detect that a line was present. My simulator has no such issue.

In my testing, I had no such issues in either direction nor with any timing, I had factory reset both the 502 and 503 before setting up. Both devices are connected to the same LAN segment (10.10.10.X).

The 502 is IP 10.10.10.124. the 503 is 10.10.10.125.
Using the FX1 port is 5060 on the 502. Using the FXO port is using 5062 on the 503.
The 502 is using user 100 and authid 100. The 503 is using 101 and authid 101.
The SIP server on the 502 is 10.10.10.125:5062. The SIP server on the 503 is 10.10.10.124.
Both 502 & 503 are set to not require registration.
Both 502 & 503 are set for Stage 1 dialing
Both 502 & 503 are set to allow outgoing call without registration
Both 502 & 503 are set to inband DTMF. (optional, use whatever works for you)
The 503 is set for Number of Rings to 1 and the PSTN Ring Thru FXS is set to No.
The 503 Wait for Dial Tone is set to no.
On the 503 Basic settings page the VoIP unconditional call forward is set to extension 100, sip server 10.10.10.124, sip port 5060.

When I pick up the phone on the line simulator and dial a number, this simulator will send the call and ring voltage to the FXO port of the 503. The 503, will see the ring (set to 1) and then use the VoIP unconditional call forward to 100 which is the User on the HT502.

Conversely, when I pick up the phone on the 502 and dial and number, the 502 sends the SIP string to the 503 as it is the SIP server for the 502. Assuming the 503 is able to see the POTS line, it will go off hook and dial the the number and I get a ring at the phone connected to the line simulator.

Girogos, the line light will only go on once the 503 has gone of hook and successfully seized the line.

You may need to adjust some settings in the FXO termination settings of the 503.
Try changing the disconnect threshold to 400ms first and try.
If you have VM indication or other on the POTS line, you may need to try changing the Minimum delay before dialing PSTN number to a higher value. This allows the line to “debounce” from the stutter tone or other condition. As I do not have these issues with the simulator, the settings are at the default,

However, I have had to change them in the real world and in one case, I has to get a loop current booster to bring the line back to limits, These are electronic hook switches and need to detect line presence unlike many analog phones.