HT503 + Freepbx Doesn't release pstn line on hang up


Hello, got HT503 with last firmware and FreePBX 12.0.76.
My problem is that when I get an incoming call, and person on-inside (on the pbx phone) hang up, the line is not cleared and is still busy for exactly 60 seconds.
This problem doesn’t appear when the call start from the pbx.

I attach some logs, from the HT503 SysLog function.

The first one is from an incoming call that is hanged up from inside (from the extension on the pbx). that’s the problem!

The second log is from an incoming call that is hanged up from outside. No problem here cause the pstn line is immediatly released.

Any help would be particularly appriciated.


I think to be near to focus the real problem.
Noticed that the problem only appear if the call is started from outside and is hanged from inside the pbx.
If the call start from the pbx internal side no problem at all!
I f the call start from outside but is hanged by outside, no problem at all!!
That’s weird isn’t it??

Analyzing the Grandstream logs I found that when I hang up from internal phone (and the call started from outside) the log contain these lines:

IFX_TAPI_EVENT_FXO_APOH event received on port 1 ch 0, status=CALL_COMMUNICATION
Dispatching event: 34 (LINE_APOH) on port 1:0
ATACtrl::processFxoLineAPOH on port 1:0, status = CALL_COMMUNICATION/CALL_IDLE
SIPStack(0)::run: Active transactions: 1
SIPStack(0)::receiveMessage:(600)BYE […]

I think the real problem is that the ATA receive some kind of tone that make it start listening for something: that’s what the CALL_COMMUNICATION status is for.
So, when the sip “Bye” command is issued the line is not released cause the ata is waiting for “COMMUNICATION”.
That’s why after 60 secs of nothing (no communication) the ata finally release the line.

Anyone knows something more?


You need to set FXO correctly. Line is not drooped as signal are not set correctly.


Think you’re right, but wich settings do I have to modify?
Any hint?
Here is my actual FXO settings.



The ATA configuration needs to match the PSTN network specifications for hangup, such as Busy tone, current disconnect, polarity reversal etc.

You can test the following settings for Italy :

  • Under Advanced settings :

Dial Tone : f1=425@-10,f2=0@-10,c=200/200-600/1000;
Ringback Tone : f1=425@-10,f2=0@-10,c=1000/4000;
Busy Tone : f1=425@-10,f2=0@-10,c=500/500;
Reorder Tone : f1=425@-10,f2=0@-10,c=200/200;

  • Under FXO port :
  • Enable Current disconnect : NO
  • PSTN Disconnect Tone : f1=425@-10,f2=0@-10,c=500/500;
  • Wait for dial-tone : NO

Best regards


Thanks for your help but didn’t solved the problem.
I’m wondering if is possible to bypass the problem lowering the timer of 60 seconds that finally hangs up.
Do you know how to change it, and which consequences could cause to other system’s functionality.
Best regards


Tones depend on country, if they are set correctly then line go down correct.



When you hangup the call from VoIP side the ATA should receive a “SIP BYE Message” which will be converted by the device depending on the FXO termination method. When the call is terminated from PSTN side the ATA will receive the hangup signal (Busy tone for example) and send BYE message to the device in VoIP side.

From the Logs provided the ATA seems to have the correct behavior, you can see the BYE Message sent (Log1.txt) after "Call completed " and “On-hook” status in Port 1:0.

In order to investigate more on this issue and have more details, kindly open a ticket in our helpdesk portal from the link below :