HT503 - firmware upgrade via GUI failed?



I just received a new HT503 which I noticed was running firmware with version 1.0.15.x (I don’t recall exactly) and attempted a firmware upgrade via the web GUI using the file (containing ht503fw.bin) before I configured it further.

The upgrade said it was in progress and asked me to wait while it rebooted, but after I guess it rebooted, I could no longer access the web GUI at all - the device would no longer respond on port 80 or 443. I can still telnet to the device but plugging in a phone to the FXS port doesn’t give any response either.

This is the status I can get via telnet:
HT-503> status
Product Model: HT-503 V2.0A
MAC Address: x (removed)
IP Address – 10.x
Netmask –
Gateway – 10.x
DNS Server – 10.x
DNS Server – 10.x
Software Versions:
Program –
Boot –
Core –
Base –
Extra –
Port Status:
Port 1: (null) (null)
Port 2: (null) (null)
System uptime: 143
System load: 0.22, 0.17, 0.06
Memory Usage: 14643200/4571136/0/1187840

I did also try a factory reset via telnet which didn’t seem to change anything. Running ‘upgrade’ via telnet says something along the lines of the update .bin files not being applicable.

Is there anything I can do to get the device back up and running? I opened a case via five days ago but haven’t yet seen any response…



I have the same problem


WAN port can be blocked, try using LAn port for access to device.
If not help make Factory reset.


From the look of the telnet results, it looks as though the HT either did or at least thinks it did take the update given the base & program of It is also picking up the network aspects.

If you connect an analog phone up to the device and then press *** on the keypad, what happens?


@lpneblett: When I connect an analog phone to the ‘phone’ port it’s just like it’s not getting power - I don’t get any DTMF tones when pressing buttons.

@Marcin: Also I’m trying on the LAN port where telnet works to I get an IP via DHCP and can telnet in, but the device doesn’t respond on port 80 so no HTTP access still.


Oh and I’ve also performed multiple factory resets both via telnet and by holding the reset button on the device.


Ok, lets try harder way.

DHCP option 66 on router(with your PC IP), TFTP(D) on your pc.
Gateway should request firmware from you PC, try upgrade/downgrade fw (as we do not know which fw is in gateway only one of firmware can work). This shold replace broken fw in gateway and allow you to regain control. If you do not know how to do it just say (and explain what you can) someone for sure will give you more detailed how to do it :slight_smile:


Just to close this out - it took me ages to get around to trying this, but having needed TFTP for something else I gave it a try today and now my HT503 is responding again to HTTP as it was out of the box!

This is what it shows via HTTP status now:

Product Model: HT-503 V2.0A
Software Version: Program – Bootloader – Core – Base –
Extra – CPE –

Looks like that ‘extra’ version has changed…

The specific thing I did was set Option 66 on my DHCP server (using a Windows server for DHCP) to point to the IP address of my TFTP server, and in the root of the TFTP server I just put the current firmware file I had previously tried to upgrade via HTTP - ht503fw.bin.

At boot the device tried to TFTP request its specific XML configuration file and some other files (like ht503corea.bin, ht503basea.bin, ht503proga.bin, ht503extraa.bin) but eventually it got to ht503fw.bin and downloaded it, clicked as it rebooted and was accessible to http via the LAN port.

Thanks for your help Marcin! I’d suggest that maybe this looks a little bit like a bug with upgrading firmware via HTTP, or the process to do so isn’t as obvious as I assumed it was when I started :slight_smile: