HT-503 & MDU Enterphone


I’m trying to use the FXO port on my grandstream HT-503 device as a way to send my building’s Enterphone calls to my cell phone.

Some background.

I live in a multi-dwelling unit building (condo complex). Our building uses the Viscoint Enterphone 2000 system that sits between the telco and each suite’s incoming phone lines.

When someone dials our suite number the Enterphone rings our phones with a distinctive ring. It’s kinda like Ring + Short Pause + Ring + Long Pause.

In addition, if we’re currently on a call through our telco, the Enterphone cuts in with a destinctive call-waiting tone.

We can answer that call-waiting the usual way, with a hook flash.

My issue is that the HT-503 doesn’t even recognize there is an incoming call.

I’ve done a hard reset of the HT-503 then set it to answer the FXO port after 1 ring. So no account registrations. No forwarding. No nothing. Just to see what it’s default response is.

Test call from my cell phone to my home number, and the HT-503 picks up and gives (what sounds like) a dial tone.

(Good it recognizes the call.)

I then head down to the Enterphone and dial the suite. The phones ring in the suite, but the HT-503 doesn’t pick up.


So as a test I disconnect my telco’s service feed into the Enterphone system. This leaves my phone lines totally dead. However now I’m certain the only thing attached to my HT-503 is the Enterphone. No telco to cause any issues.

I go down to the front door and ring my suite from the Enterphone again. Sure enough the phones ring but the HT-503 doesn’t recognize the call.


Again. I have done a clean factory reset on the HT-503. The only setting I changed after that was the number of rings before it answers. I’ve tried 1 and 2.

Prior to the clean tests I’ve also tried to change the system ring cadence to more closely match the ring cadence of the Enterphone system. C=800/400-800/4000.

Anyone have ANY advice how to make the HT-503 hear the rings from the Enterphone?