How to use Caller ID from Extension instead of Trunk (Multiple DID's)


#1

Hi. I’ve just recently started using a SIP trunk from VoIP.ms instead of the FXO lines. The trunk has multiple DID numbers, each of which has their own Inbound Route in the UCM.

Example: DID 1 goes to Phone A, DID 2 does to Phone B.
What I’d like to have happen is: Outgoing calls made from Phone A, have the caller ID show the Caller ID as the phone number of DID 1.
Outgoing calls from Phone B should show CID of DID 2.
I have set CID’s accordingly in the Extension configurations.

However, after experimenting with the VOIP Trunk settings, I get:

  • On the Advanced tab, If I check the “Send PAI Header” and fill in the PAI Header manually with CID info then all outgoing calls, no matter where they originate from, use that CID–which is understandable. I can see where that would be great in a situation where a number of DID’s are used for incoming calls but a single CID (say, main office number) is used on outgoing, so people receiving the outgoing calls would always see the main office number on their display.

My situation is a bit different. I have a UCM 6104 at home and have two DID’s–one for a ‘Home’ number, one for an ‘Office’ number. It would be nice to have the outgoing CID’s match, so that if I call back someone on the ‘Office’ line it doesn’t show the home CID, or vice versa.

  • If I uncheck the “Send PAI Header”, then the outgoing CID goes to the SIP Account specified in the “From User” field from the Basic Settings tab–unrelated to any DID.
    I’ve tried checking/unchecking various combinations of other parameters, but have not stumbled on the right combination.

Can anyone tell me,please, what combination of settings needs to be in place to have the CID specified for an Extension to be used for the outgoing call CID?

Any help would be appreciated. Thanks.


#2

Look at manual and read up on DOD settings.


#3

Thanks. I did setup the DOD’s as per the SIP Trunk Guide. But when I uncheck the “Send PAI Header” it reverts back to my account number again. I have tried checking “Send PPI Header” and setting PPI Mode to “DOD Number”, also tried checking/unchecking the “DOD as from name” box. After every try I call the “1-555-555-0911” number to have it read my caller ID and it is just the account number, unless I hard code the CID with “Send PAI Header”…

The Trunk Guide mentions nothing about the actual settings needed here…


#4

The DOD settings referred to in a previous post are in the VoIP trunk settings. You set up a DOD and put specific extensions in it. Then you specify the CID you want those extensions (or a single extension) to display. I don’t know if there’s a limit to how many DOD’s you can set up per trunk, but if there is I haven’t found it yet. I believe I have set up as many as four in previous UCMs that I have programmed.

Make sure you have e911 programmed on the numbers you wish to display, or use the Emergency Call feature under the extensions if you need to display a different number if/when the extensions in question ever call 911. My go-to provider charges $85 if a 911 call displays an incorrect DOD number.

But lpneblett is correct - the manual explains this feature adequately enough that I could figure it out. :slight_smile:


#5

Sorry, didn’t see this post when I posted previously. I haven’t had to mess with the settings you’re referencing, I just set up the DoD as shown and it worked on every system I’ve set up so far. I’m reasonably certain that I left the settings you’re referencing at whatever the default was when I originally set up the trunk.


#6

Thanks, but like I say, I’m at a loss with regards to the settings. The odd thing here–with the DOD settings–is that it appears the CID settings specified in the Extensions do nothing (which is fine, so long as you know that). The DOD settings for the Trunk are very easy to setup–and great–but my problem is more with the settings in the Trunk Basic and Advanced settings relating to how to get the DOD settings out rather than either my hard-coded CID or the trunk using my account number…
Maybe what I should do is try to setup a new trunk and see what the defaults are.
Thanks again…


#7

I should mention my Trunk settings were originally changed from the defaults since the trunk is Encrypted. I fought with that for a long time until I discovered that settings in the PBX/SIP settings needed changing to allow for that. But I’ve looked them over again and I don’t see where they should be affecting the CID stuff…


#8

When I look at the System Status/Active Calls, it shows the CID of that extension, but on the called external phone (my cell phone) it shows as the CID that is in the “Send PAI Header”. Aby other changes I’ve made come up with a Server Error…
Unless somebody has something to suggest I think I’ll just leave it as is, at least the system is working other than the DOD CID issue. I’ve reread the Manual and the Guides multiple times but have not been able to solve this–which is frustrating…


#9

What have you set for the caller id number on the voip trunk on the first page … any chance of taking 2 x pictures of the front and advanced pages of Voip - remove the voip.ms reg details…


#10

The issue is that you need to know from what SIP header your provider is taking the CID.
Additionally, the UCM has several locations by which to manipulate the CID and these may or may not be the same fields.

My provider allows me to manipulate the trunk settings on their so that I can choose from which field they will take the CID. As you stated in one post, the provider was using your SIP account number, which I suspect may have been taken from the “From User” setting in the trunk settings.

Below is an INVITE to the provider -

When looking at the INVITE the fields/headers of interest are the From, P-Preferred-Identity (PPI) and Remote-Party-ID (RPID). You will note that all are different.
I did not have PAI enabled for this exercise.

The FROM is equal to the FROM USER setting in the trunk.
The PPI is taken from the USERNAME setting in the trunk
The RPID setting is taken from the DOD setting associated to extension for a given trunk. As you can change the CID for a given extension on a given trunk, this provides for a somewhat dynamic CID for a single extension when dialing out different trunks.

Now then, there are other areas in the UCM where you can influence the CID. A couple of such locations are:

  1. In the extension settings in the UCM under CallerID Number. I suggest leaving this blank.
  2. In the trunk settings using those field mentioned above as well as PAI, Keep Original CID or Keep Trunk CID.
  3. IN PBX settings, Global, Global Outbound CID.
    There are other settings in the SIP settings area that can also influence what is sent such as “send RPID” and enable passthrough PAI.

While some settings are pretty set, some are not so much as you may want to present a different callerID for a given situation. So, when you call the house, you probably want the your specific extension CID to show. However, if you have forward set and the system sends a call to your cell or softphone, you may not want to see your extension or even that of the trunk or business, but the CID of the original caller.

You first need to see what the provider requires and if it you have the flexibility to change the field from which they acquire. The most common fields are FROM, PAI and RPID. At the moment, however, I am guessing they are using the FROM field and you have your account number/username listed.


#11

Here are the settings as currently configured…



#12

As it shows there, I do have the “DOD as From Name” checked. I also unchecked the “Enable Passthrough PAI” in the PBX Settings, as well as cleared the CID global settings there.
I really appreciate the help, perhaps I will also send a link to this to the support team at VoIP.ms, in case they can shed some light on things…


#13

Okay… straight away I see one problem, make sure the From Domain on the first Voip page has the providers url/ip address there… I normally ensure that the NAT check box is also selected…


#14

OK, I will try those, but I have tried both before…


#15

We are running into this same issue. Where you able to resolve this issue? If so, what were the final settings that you needed to change/enable?

Thank you.


#16

I had a project with 40+ DID’s and had a hard time with this as well. I ended up created and outbound route for each DID then enabled on the outbound route :Enable Filter on Source Caller ID and selected the extension to use that route. It was a real pain but it worked.


#17

I use this method to use the extension field as the outbound cli.


#18

I see on the first screen, the Basic Tab of the SIP Trunk settings, your User = Phone setting.
What do you have in the SIP Trunk, Advanced Settings tab? Do you have anything in the PAI Header?

In any case, this has finally resolved the issue for me, Caller ID works great, First Name + Last Name shows as Caller ID Name, CallerID Number shows as Number! Superb! Thanks very much–your suggestion is much appreciated…


#19

Good to hear it’s resolved.


#20