How to set up phone with wi-fi OR ethernet?


I am trying to set up my work phone, but am having an issue with the password for the wi-fi. First, the instructions say: go to menu, done. Go to “network settings”, then to “wi-fi”, the only thing I see is “network”, no “network settings”. While in “Network” I get two choices; “wi-fi band” or “wi-fi networks”, So I pick “wi-fi networks”. It says to: set wi-fi to “on”, there is no “on” to turn on. So I move on to picking my network, I highlight it, it shows excellent, then go to “security mode”, “options” and “modify”. Then go to “password” I am assuming it’s my wi-fi key code/password? So I start to enter it when I come to the letter “O” or is it a “0”? If it’s a “0” HOW do I get a “0” using the buttons, because it is very strange, something that should be SO SIMPLE doesn’t seem to work. Additionally, how do I see my PW/key code so I know I don’t make a mistake? I have added BOTH the “O” ad the “0” with the way I “think” is works (can’t see the entry, so I don’t know if it’s the letter or the number) and it saves it. yet I can never get my phone to work!! I am totally frustrated. Please help! PS…would it be possible to add this phone to my ethernet on my computer instead? That may be way easier for me, I use Windows 11 on my PC? Thank you.


Avidcomm, thank you for your response, I appreciate it. Using your directions starting with system, my phone does not have a system button anywhere, I have checked over and over again. I am using the Grandstream WP810 phone. The booklet says go to menu>settings>network settings (which I also do not have, I only have network) then it tells me to go to wi-fi. So since I only have network, there are only 2 choices within network to choose from, I have either wi-fi band OR wi-fi networks. I have tried them both to no avail. Step 2 in the booklet says set your wi-fi to on, I do not have an on button to turn on. Step 3, select the desired network to connect to…


Mgoulet, Sorry I assumed it was a different Phone.
On my WP810 It is Menu>settings>Network>
At this point you should see:
Wifi Band
Wifi Networks
Country code

My WP810 is on system version


Hi Jeff, yes, I see all that and for wi-fi band I put in wi-fi 5g and for wi-fi networks I scrolled to my network, and country code added US and saved it. So far so good. Is the system version something I need to deal with and how do I get my phone working. It’s weird, I turn it on and hear a dial tone, but can’t dial out AND it is constantly saying I’m disconnected from wi-fi, yet I have a dial tone?? Is there a way to connect this phone to am ethernet line?



Wifi connection is one step, With what server are you connecting?
Don’t worry about software level at this point I only mentioned it for reference.


I am using


Hey Jeff, would it be possible to call you? This is a work phone, I work from home and my boss is getting crazy that it’s not online yet. Lol


I have have already tried calling 617-566-9300, to no avail. Apparently it’s for sales people and not troubleshooting. You can call me on this line if you wish: 775-990-1559. I needed to be online yesterday and the phones have gone live today already!! I need help!!


Jeff, in the instruction booklet it says “set wi-fi to on” . How do I do that since I have been through every single thing you can push and I have never seen a place where you can set the wi-fi to on. Please give me the step-by-step to turn it on, don’t assume I know anything. Remember, I’m using the WP810 Grandstream phone. THANK YOU!!


Just as you may have a phone at home that uses a wire to connect the phone to your telephone provider, the same is true in that you have a Wi-Fi phone that is connecting to a Wi-Fi network such as that performs the same function as the wire at home - a connection. This is the question that Avidcom posed when he asked what server are you connecting to. Is it a IP-PBX, a SIP trunk provider or ??? The WP does not just magically provide telephone service, but rather it has to be programmed to get the service from another device which has to be made aware of the WP phone and the other aspects of how to provide telephone service so the WP can be used.

This is the part that has to do with the settings in the phone for registration. Please obtain the admin manual and review. There may be some videos on YouTube that also provide some background.


Hi Ipneblett, To your point, Jeff was so kind to call me and he figured out what the problem was, exactly as you have stated. The functionality wasn’t working on my phone properly (so I did not have a wi-fi on button) because the System Version was extremely out-of-date! My phone showed a version when I apparently needed a or higher! This is the issue and I am SO GRATEFUL to him (and now you!) for figuring it out. Now I can get this updated and be on my way. This is a GREAT system for help and I want to thank you for trying to help me as well! :slight_smile:


Jeff, I want to THANK YOU for figuring out why I couldn’t get the functionality to work on my phone. This platform for troubleshooting is GREAT! I really appreciate it greatly!! You were so kind to call me and help figure things out. You made my day! Now I don’t look like a stunad to my boss! :wink: Have a wonderful rest of your day!!


I did nothing. Jeff is who got you up and running and is the one that deserves the credit.