How to set Inband and RFC2833 DTMF modes together in grandstream UCM6510


#1

Hi,

I have a problem with setting up DTMF mode for UCM6510. I used it for my sip trunk line with IVR. And when DTMF inband mode is set, analog (PSTN) line can call our call centre and they can press any number to redirect to agents. But mobile users can’t press any number to redirect to call centre agents.

But when DTMF mode auto is set, Mobile use can call the call center agents but PSTN line couldn’t press any keys to redirect to call centre agents. Does anyone have this experience before ? Please advise how we could fix it.

Thanks.

KT


#2

always set RFC2833 on all trunks and phones and you’ll never have a problem. RFC2833 is the most widely used and functional standardised method.


#3

Hi @damiano70

Thanks. We will give it a try.


#4

It doesn’t help. Is there any alternative to address this issue?

Thanks.


#5

I honestly don’t understand exactly what the problem is,
if you describe the scenario in detail, it might help


#6

Hi Damiano70,

We are using SIP trunk from one of local providers. We have the IVR in UCM6510. When customer calls us by using Mobile, the customer can call the extension numbers he want. But when a customer calls us by using PSTN line from another telco, he can’t call to extension numbers directly. We changed the DTMF mode Auto, Inband, RFC2833 in order to solve for customer those are calling from PSTN line (which is analog) but we can’t solve. So we are finding a way to solve it.

Thanks.


#7

Are you sure you have correctly set the country etc… in the parameters that I attach on the screen ? (of course they are examples referred to my country) and have done correctly the various tests “detect” and “ACIM Detection”
if anything, set the screens of the various settings if it still does not work


#8

Hi Damiano70,

I didn’t check this yet. I will check those and give it a test. Will update here again.

Thanks.


#9

the two tests that I told you serve to align the tones etc. … between the line PSTN and UCM, maybe you do not solve but it’s a good start.


#10

I searched for those settings and I found those. Those settings for Analog trunk. I am having issue with IP trunk and I still couldn’t figure it out.


#11

so if I understand well on the pstn trunk is now solved and you have to solve on the ip trunk?
You said that on the ip trunk there were no problems …