How to customize an unconditional forward without the '*' (asterisk character)?


#1

Hi,

we have client using the GXW4232 and I would like help with a problem with dial plans.

The IP PBX(Asterisk-Based) to which Grandstream connects uses the characters ‘*’ and ‘#’ in its internal operation. So, the ippabx bypass the command sent by GrandStream and I can’t use functions like ‘unconditional forwarding’ (code * 72), for example.

How could I change the dial plan to consider only a pre-established numeric code, such as 999 + anyExtension, to activate the redirect?

Many Thanks!


#2

Turn of GXW feature codes.


#3

Hi, Marcin.

Thank you very much for your attention.

A detail I forgot to mention: This ‘unconditional forwarding’ feature must be available for the phone user to activate and deactivate it. Unfortunately, I can’t just configure it on IPBX (a feature that already exists and works).
So, I believe that I could not disable feature codes, since it would make it impossible for the user to use them, right? Or is there a way to disable them and still allow the phone userto activate / deactivate ‘unconditional forwarding’ when he wishes?


#4

Then reconfigure GXW features so they not collide with Asterisk (if you do not see this then you have old fw).
Asterisk have this function, no idea why you cannot use it (code can be changed afair).


#5

Hi, Marcin.
Again, thanks for your time and help.

I’m probably not being clear, so please, let me try again. My question is: is there any place in GXW where I can substitute the command character * for another one?

The scenario is: the agent, who uses a phone connected to the GXW, needs the freedom to activate and deactivate ‘unconditional forwarding’. By default, GXW code features start with * (asterisk character). I need to find a way to allow the phone user to activate ‘unconditional forwarding’ without having to start the command with the * (asterisk character).

Note: I did some tests yesterday replacing the code features (I deactivated the other code features and inserted code 99 as ‘unconditional forwarding’; then, in the dial plan, I established that the extension could enter 99 xxxx), but all I got was the message of an invalid number. I believe this is because he does not consider 99 as a command, as there is no * in front of the number.


#6

I get it now.
I do not think it is possible. You can try change it via dial plan, but i think it will be sent to PBX instead of local.
Why you want use asterisk to set unconditional forward instead of local gateway ? (then dial plan will work for sure).