How to change the ring tone in WP810 phone book?



Hi all,

I’ve noticed that all my entries in the phone book get the ring tone “Don’t mess wiv it” assigned. Even if I (in the phone, not the web interface) manually select another ring tone from the list, the change does not become effective. It pretends to store changes (in fact, if I change another item in the record, this gets saved), but after a reload of the entry it again says “Don’t mess wiv it” (if it weren’t so annoying, the name would be funny)
I can’t change it via the web interface either (ring tone entries not shown at all).
Any ideas, anyone?

FW is
Best, Soeren


have you tried clearing the cache?
tried to change Browser and use it in “incognito” mode


yes, no change in the phone book entry visibility.
There’s no access to the ring tone via the web interface.


The device is managed elsewhere… you can not locally manage it… speak to the provider.


Every time the device reboots it will pull the same configuration down.


There are no ringtone settings available from within the phone book. The admin manual shows the relevant fields to change and where in order to change the ring tones, but as Scottsip indicated, if the provider is managing the phone, then they are controlling what can and cannot be changed.

The ringtone is generally manipulated by the alert-info header or matching a callerID to an inbound call.


Hi all,

thanks for all the answers so far.
The phone is managed by myself and connected to a “Fritzbox” via a SIP account.
I set the ring tones in the accounts (only accessible in the phone, haven’t seen the field in the web interface), but the phone plays something else that made me courious.
Calling in from a number not in the phone book => plays the sound set in the account => ok
calling in from a number listed in the phone book => plays “Don’t mess Wiv it” (which is the name of a ring tone :wink: ) => not ok, so I went to look where this is coming from.

Good to have confirmation that there is no settings regarding ring tones in the web UI.
But there is an entry in the phone book.

When I now try to alter it into something else

and save it, it seems to not become effective, see

It’s the local phone book in the WP810, I do not use an external one nor LDAP
The weirdest thing is… if I download the phone book as xml, the record seems to be correct:
> 7
> Andromeda
> 0
> 0
> 0

Any more ideas how to get rid of this ring tone?


Where did you get the phone? The ring tone, does it sound like the one in the link -

If so, that is not a GS ring tone as someone else has placed that one in the device. Look to see if there is a config server programmed in the device and if so, what is it?


It’s exactly this sound. I bought it from a German distributor. It looked genuine, with all seals on the packaging.

Indeed, there was a config server configured, the one which is in the factory defaults:
I’ve deleted the entry, but no changes so far.


The config server is a GS entry, so no issues there.

Have you tried a factory reset?


saved config, factory defaults, restored config and the entries have the phone book entry that I expected.
Also, I can now change and successfully store the ring tone entries in the phone book. Problem seems to be gone.
@lpneblett et al, thanks, guys!