How to Change the Default system tone ON DP750 & DP720?


could you private message me your ringtone so I will be able to test on my device? thanks



or you can directly upload it to this post if you feel comfortable. @chucnkwana


acctually it was controlled the ring tone accroding to external incoming call tone and internal incomming ringtone and hand set , on asterisk server by programming so that was the reason that could not able to set or change system ring tone on DP720. and finally we change the programming after that we were able to change the system tone.


This is the issue I am facing. Across all phones using the factory and custom ringtones


I raised a ticket with Grandstream and sent a PCAP - They said it was in the INVITE request the Alert-info header was set to Bellcore-dr1 ringtone and this needed amending in call manager.

I set up a SIP normalization script to remove the header but that didn’t work.

I checked further and found an Ignore Alert-info header setting in Grandstream GUI. Changed this to Yes and it worked.

Profiles>Profile1>SIP Settings>Basic Settings>Ignore Alert-Info header - Change to Yes.


Hi, can you please tell me what exactly what I must enter in each field and option of the image? I can´t make it work.

My file is here:

And this is the Firmware page:

Strangely, besides, I select Check every day, and it doesn´t take the changes, it always comes back to “every week”.

  1. Prepare for the ringtone file:
    a. Make sure the ring1.bin file is less than 128KB
    b. It is recommended to create the ringtone by the tool “Grandstream IP Phone Custom Ringtone Generator” at our official website:

  2. configure your device Firmware Upgrade page like below:

  3. Reboot your device. Your device will download the ring1.bin file automatically after reboot.

  4. Enable the Handset to use the custom ringtone:
    If the ringtone format is valid and downloaded successfully, you will see the ring1.bin file is selectable at below screenshot, you can set it for each handset. DP7xx support max 10 custom ringtones on the base station, but only allow the handset to choose 1 to use.

4 . Configure on Handset UI to use the custom ringtone:
Now your handset is able to use the custom ringtone you configured, but that does not mean you have to use it, you can still configure the handset to use it or not, to do this:
Go to your Handset -> Audio -> Ringtones, you will see the custom ring option, select it to use.


Thanks for your quick reply! That exactly is one of the attempts I made. Exactly what you said. But it doesn´t work. I think that the DP750 doesn´t take the changes because when I reboot, the deafult firmware address reappears ( or similar). And I select Check Every Day, but it doesn´t stay, it comes back to Check Every Week.


Are you using UCM Zero config to provision the device? Make sure disable the UCM provisioning for your DP750 and remove the Config Server Path at the Provisioning page. then you can “save and apply” the changes at Firmware Upgrade.
Because if you are using UCM Zero Config, when DP750 is booting up, it will try the Provisioning first, after that, the Firmware Server Path will be restored to, then you cannot download the ringtone bin file from your FTP server.


Thanks for your reply. Yes, I had the DP750 in the UCM6202 Zero Config. I deleted it from there (twice, because it reappeared), rebooted the UCM and tried to remove the server path in the Provisioning page. But it is the same, when it reboots, the server (, being 1.128 the UCM) reappears.

  1. Do you know why?
  2. Do I miss out some benefit removing the DP750 from Zero Config?


It is zero config feature.
Instead of remove simply change setting in UCM template for this DP and provision.


Hi! I don´t understand what you mean or how to do it.


Edit device settings in UCM zeroconfig


Ok, I will try that. Do you know if that is also the reason why I can´t change the Time Zone? I change it, save and apply, and it comes back to “self-defined”.


I changed the Time Zone in the Zero Config, saved, reboot both devices twice, and nothing, the time zone returns to self-defined. And there is no field to introduce user and password of the ftp server here, I can´t do it from here.


If you cannot configure the username and password in UCM Zero Config, I think you can just configure it in the device Web UI.


DHCP can overwrite time zone or NTP.


Hello. This is for all who look for a solution to this. The only solution to the changes not being saved was the new firmware released two days ago,
And for the ringtone download, it worked for me only in HTTPS, not in FTP. I made a folder and inside I put two ringtones.
You must go to Provisioning, not Firmware server.
In the firmware server path you must put the site and folder, without the file name. I put in server: “”. Only that. Now I can´t make the phone delete the sample .bin I used, but that is another story.