How to change "From" field in SIP Header


#1

Hi guys
I have topo below:

-------- LAN1(X.X.X.X) UCM6510 LAN2(Y.Y.Y.Y) ------ (Z.Z.Z.Z) SIP PROVIDER

When I call out, UCM send a SIP request from Y.Y.Y.Y to Z.Z.Z.Z but in the “From” field of SIP Header I see:
From: “0abcdef…” <sip:0abcdef…@X.X.X.X; …

SIP Provider expect UCM should send:
From: “0abcdef…” <sip:0abcdef…@Y.Y.Y.Y; …

How can I do it ?

Thanks


#2

It might help to know what XXXX and ZZZZ represent.

On the one hand, if XXXX represents what is in the From Domain field in the trunk settings, it may be correct.


#3

I have exactly same problem:
PBX LAN: 192.168.147.14 (phones here)
PBX WAN: 10.137.4.2
peer trunk provider expects from us:
SIP INVITE FROM : sip:100@10.137.4.2;
but we send:
SIP INVITE FROM : sip:100@192.168.147.14;
and we get 403 forbidden.
We tried switch NAT on in trunk setting and/or PBX settings-SIP settings but anyway we have local IP in outbound packets.
[lpneblett], AFAIK there is no that field in “peer trunk”


#4

Show settings in PBX Setting, SIP Settings, NAT


#5

Sorry for delay. You were right, “From Domain” + DOD is what we needed.


#6