How do I set outbound trunk by extension?


#1

Is there a way to set the outbound trunk by extension? I need to use different outbound voip trunks per extension so I can have costs attributed to the correct account. For example extension 101 should dial out ONLY on Voip-1, ext. 102 should dial out ONLY on Voip-2, etc.

I can’t see how to set up an outbound route that would accomplish this. Can someone help me figure out how to do this?

Many thanks.


#2

In Outbound Routes use Enable Filter on Source Caller ID to specify which extension should use that route (VoIP trunk).


#3


follow above post from drostoker


#4

Thanks very much. There are so many options it can be difficult to find all possibilities.


#5

As soon as I Enable Filter on Source Caller ID it disables the Privilege. How can I use it then? How can I set the Privilege?


#6

You setting the rule for the each user you normally match an outbound rule with local , national , international ( remember these names are confusing because they do not represent local , national or international dialing) they more a level of privilege form low to high.

Now you are assigning a user directly to the outbound rule it is the highest level his ability to call will be based on your rule for eg _x. he can call anywhere he like even international , if your rule is 012345678910 556677889900 then he can only call those 2 numbers…

so your privilege is based on your dial pattern now


#7

Thanks for your reply.

I’m still having problems with getting this to work. Here is my setup:
I have 4 voip trunks, each a different voip account. I have 4-line phones. Each line registered as an extension. So phone-1 has extensions 101, 102, 103, 104. phone-2 has extensions 111, 112, 113, 114. phone-3 has extensions 121, 122, 123, 124, etc. I have setup extension groups grouping 101, 111, 121, etc.

Each extension is a Single SIP. In each extension I have set the callerID number to the corresponding trunk CID. In the Outbound rule I set the Outbound Route CID to the corresponding CID and the correct voip trunk (though they are not shown in the attached images.) As you can see from two of the Outbound Routes that I have attached, they each have the same pattern.

When I attempt to dial out from ext. 102 (which is part of WPMG extension group) it should dial out from that account. It doesn’t. Instead I get a message: “The call was rejected by the server”. When I dial out from ext. 104 (which is part of Waterline extension group) it does dial out from the correct account.

The only thing I can think is happening is that both outbound rules have the same pattern which is what I want for dialing out. This is the purpose for my original post. Why is this not working? What am I doing wrong?

Thanks for your help.


#8

Remove the CID from the extension. When blank, it uses the extension number and this is what the system uses to filter which extension is able to use the rule. Set the CID in the DOD section of the trunk.


#9

Thanks for your reply.

I removed the CIDs from the extensions. I also set the CID in the DOD section of the trunk as you suggested. Dialing out still only works on ext. 102 (WPMG group ext.), but not on ext. 104 (Waterline group ext.) On that ext. I still get “The call was rejected by the server”. I even rebooted the UCM.

I have included screen shots of two extensions and two trunks. I hope this helps point the way to a resolution.

Thanks for your continued help.



#10

I think Larry intends to tell you to activate the CID on the Trunk DOD


#11

I believe I did activate the CID on the trunk DOD. Here is a screen shot of my Waterline trunk DOD:

Is there another setting that I’m missing somewhere?


#12

if you set everything correctly there should be nothing else, refer to the manual anyway


#13

Show the outbound rules/


#14

Hi Ipneblett,

I did post it above. But for convenience here are two again.

Again, thanks for your continued help. This is the last hurdle for me.


#15

So the question is where is the rejection coming from - the UCM or VoIP.ms?

To find out a network capture is needed.


#16

where is the rejection coming from - the UCM or VoIP.ms?

Yes, exactly. How do I do a network capture?

I just had a look at the CDR detail. It looks like the outbound attempts were made through the correct trunks. Throughout this process I have been able to dial out of both voip accounts at different times, but never together. I need to look into how Voip.ms might be causing this issue.

Thanks for your help. I’ll get back with any follow-up questions.


#17

I wanted to let you all know that after much hard work and network tracing by Voip.ms we discovered the problem.

As you will recall I was getting “call rejected by the server” errors when trying to call out on different lines. It turns out that my voip trunk account ID was the problem. I had account IDs like 12345_abcde-ucm. What we discovered is that the UCM62XX stripped the dash (-) from the account ID. So the UCM outgoing trunk ID was 12345_abcdeucm instead of 12345_abcde-ucm. That’s why my calls were rejected. It’s curious though, that one line (account) always worked even though it had the dash in the account ID.

Anyway, it was a weird problem that others need to be aware of so as not to make the same mistakes that I made naming my voip account IDs.

I want to thank everyone who helped me on this issue, and pointed me in the right direction. Now everything is working as I had hoped. All the best.