Help with sip notify (reboot phone) in asterisk using pjsip - works using chansip but not pjsip


#1

Hi GS Community!

Maybe this is more of a freepbx/asterisk question, but thought I’d check here first…

From Asterisk console I’ve been able to reboot gxp21XX phones easily with “sip notify gsreboot extension#” - works great, but I recently moved over to pjsip and I cannot get it to work.

Here is my chan_sip config settings:
cat /etc/asterisk/sip_notify_custom.conf
[gsreboot]
Event=>check-sync

my pjsip_notify.conf references the same file.
cat /etc/asterisk/pjsip_notify.conf
#include sip_notify_custom.conf

BUT when I run “pjsip send notify gsreboot endpoint 7003” I get " Unable to create request with auth. No auth credentials for realm(s) ‘MyHostname:5061’ in challenge."

Can I specify in grandstream config to disable auth for sip notify? Would there be any down side to disabling authentication for sip notify?

thanks for you help,


#2

You run TLS ?


#3

If you need TLS, go back to chansip.


#4

TLS working great for pjsip, for endpoints and trunks. Its just the sip notify I have to figure out…


#5

Does any one know the answer to this question?


#6

I do not see such option.
Run SYSLOG (with sip log) on phone and see if it receive packet first, if not then you have problem with asterisk.


#7

Just heads up a co-worker found this in the cfg of the phone to disable sip notify auth…Now we can run “pjsip send notify gsreboot endpoint 7003” and the phone will reboot. I’m not sure where this would be in the web-interface.

Each phone config needs this changed in the config.
<!–# Disable SIP NOTIFY Authentication. 0 - No, 1 - Yes. Default is 0–>
<!–# Number: 0,1–>
<!–# Mandatory–>
<P4428>1</P4428>