Help needed - Outbound call issue - 403


#1

Hello,
First post on this forum. Hi all :slight_smile:

I’m struggling for two days with outbound calls with an UCM6202 with latest firmware 10.17.16
(Problem was the same with 10.16 and 10.15).

The setup is simple, 1 GXP1630 plugged directly in the LAN port of the UCM. The UCM has it’s WAN on DHCP with natted IP (192.168.69.x).

The trunk is up, incoming call are working well. When tryin to call outside, I get the error 403 , call rejected by the server.

when calling outside Syslog is showing the following error :
res_pjsip_header_funcs.c:446: No headers had been previously added to this session.

The ethernet capture on the UCM return the following error :
Status: 403 URI domain not configured locally, relaying forbidden

I tried avery settings I can’t think of : PAI hearders, NAT, public IP, URI, PPI, …
But I’m not an SIP expert and it’s my 2nd UCM setup so I’m a bit lost.

Must me something wrong in the INVITE request but can’t find what.

If I configure the trunk directly on the phone, it’s working.

Any help will be greatly appreciated,

Thank you


HELP - outbound call issue - 403 error
#2

Try overwrite your trunk invite with
From Domain : same as host name
From User: same as username


#3

Thank you Marcin for your reply.
Last time I didn’t had the time to dig into this issue and moved to another system.

But now I need again to make it work and still have the same issue. Upgarding to 1.0.18.13 didn’t help.

Sorry but I’m not expert in SIP specially with UCM device. Can you (or anybody else) please explain how to overwrite the trunk invite ?

Thank you for your help and best wishes for 2019


#4

The INVITE is changed based upon the info you enter into the UCM’s VoIP trunk settings.

When you selected the provider you wished to use, and assuming they/you use a register trunk, they provided you with a set of credentials by which to authenticate and register the trunk. What Marcin is suggesting can be found on this page and the entries should have been provided. He is suggesting that whatever you have entered for the host name/IP should also be entered into the From Domain header and the same this for username should be entered into the From User header.

The issue you face is not related to firmware, but rather a 403 is a decline as the info received by the provider is not adequate or incorrect to meet the authentication need.


#5

Some providers have excellent tech support and might be able to tell you what you need to change. I’d give then a call.


#6

Yeah, basically providers should say what they need and where, then you set it in UCM and “change” invite packet correctly to their needs. I give only basic check, there is more that can be set. Settings this blindly is useless.