Help configuring HT813 as a trunk to PSTN (FreePBX)


#1

The HT813’s FXO port is connected by phone line to the “Tel1” port of my ISP’s Voice-Enabled Optical Network Terminal (VeONT). (i.e. ISP digitally provides an analog landline to homes).

The HT813’s WAN port is connected to my home network switch, and I have set static mapping in my router so that HT813 always gets the same LAN IP: 10.0.111.11
My FreePBX has IP: 10.0.111.10
The HT813 has the current firmware: 1.0.3.12

I test incoming calls using my mobile phone to dial the landline number, my IP-phones ring, and 2-way conversation is good. (Mysteriously, this doesn’t seem to work until the HT813 has been up for over ~15 mins…)

I test outgoing calls by using an IP-phone to dial my mobile number, and there is ringing tone heard by caller, but my mobile phone never rings. During this ringing, I refresh the status page of the HT813, and I see the status of the FXO port never changed from Idle, but interestingly , the status of the FXS port changes from On Hook to Ring. And yet I do not need the FXS port to function at all.

Is it correct for me to leave this setting blank?: “Unconditional Call Forward to PSTN: (VoIP calls will be forwarded to the specified PSTN number)” It is the second last item on the HT813’s Basic Settings page.

Oh, and is it ok that both FXS & FXO always show as “Not Registered”? This wiki.freepbx page says registration shouldn’t be necessary.











#2

The ringing you hear as the caller is likely because in the SIP messaging, there will be a 180 Ringing message from FPBX when the PBX sent the call to the HT and the HT responded back with same. The ringing is created by the phone when it sees the message and you are only hearing the ringing generated by the phone, not from the other end unless the audio path has been established.

You need to make a call while watching the HT and refreshing the status page at the same time to see if the port goes off-hook. At the same time, you need to a network capture so the messaging can be examined to see how the call progressed (or not).


#3

I was watching, and the status of the FXO port never changed from “idle”, when attempting to call outwards. But the status of the FXS port changes from “On Hook” to “Ring”. Why? I do not need the FXS port at all.

I don’t really have my network set up for capturing between those boxes though, was hoping someone could spot my config mistakes.


#4

It may not be a config mistake. As you are getting the ring, this implies that the HT received the command and is indeed trying to dial.; hence why I was hoping for a capture. It may be that the HT is unable to sense the presence of the FXO line and is unable to go off hook, which is why I asked you to monitor the line while calling.

In the HT, in the FXO Termination Section of the HT set the “Current Disconnect Threshold (ms)” to a value greater than the 100ms default. In one instance, the setting was changed to 500ms which resulted in successful outbound dialing.


#5

I just tried changing FXO’s Current Disconnect Threshold (ms): from 100 to 500. It made no difference.
Inward calls still work.
Outward calling still only has ring heard by caller. FXO status remains at Idle, while FXS status changes into Ring.


#6

The settings you have look correct. You need to do a network capture and you may also need to get a loop current tester to see if the telephone line is within specs. I have had to use a loop current booster on a couple of devices where the distance from the CO was pretty far.

You can also search the forum for others who may have seen similar and come up with a solution.


#7

I am using a new telephone wire, about 1m length, between the HT813’s FXO port and the TEL1 port of the ISP-provided Huawei VeONT. Inward calls work. There was one time while futzing around earlier with the HT813 settings, when an outward call did half-work, my mobile phone did ring, but there was no audio at all when answered.


#8

I have it working now, after changing some items according to the guide at: https://www.youtube.com/watch?v=J6oJSMDJzEI

But I think the most likely cause of the problem was that I had changed FXO’s port from 5062 to 5060 which collided with FXS’s port, and FXS’s binding to port 5060 took precedence even though FXS was set to Account Active = NO.

So I set FXO port back to 5062, and put port=5062 in my FreePBX Trunk > Sip Settings > Outgoing peer details.

Calling in both directions are OK now.

And I confirm that:

  • registration status of both FXS and FXO in HT813 remain “Not Registered”
  • Unconditional Call Forward to PSTN: [_____] (VoIP calls will be forwarded to the specified PSTN number) is left BLANK, works.
  • FXS settings can have Account Active set to NO, Sip server details all blank.
  • FXO settings > Primary Sip Server - IP with or without the colon-port-number both work fine.
  • FreePBX > Trunk > Sip Settings > Incoming tab can be totally blank.