Handset Display Time

ip-communications

#1

Hi all,

I recently bought a DP715 and everything works great… except… No matter what I do, the handset only shows GMT (or UTC) time.
I have played with all of the time related settings, but nothing makes a difference.
I’ve set the timezone to London, Dublin, etc. GMT+0. (Ok… but we’re in summer time now)
I’ve set the timezone string to GMT+0BST+1,M3.5.0,M11.5.0 (Which is correct for the UK)
I’ve set it to pick up the timezone from DHCP.
I’ve changed the various ntp settings.
I’ve even changed the timezone to Paris, Amsterdam, etc. GMT+1
But, it makes not difference, the handset still shows GMT. I just can’t get it to display the correct time ???

What am I missing?


#2

Hi NuIotaChi,

Please access to Basic Settings and set the following:

Time Zone: Using Self-defined Time Zone
Self-Defined Time Zone: GMT+0BST-1,M3.5.0,M10.5.0

Best regards,
GSsupport


#3

Ok, I’ve done that (copied and pasted the TZ string, though I’m sure it’s supposed to be BST+1)

But, it’s still not displaying the correct time. Still on GMT :frowning:


#4

Hi,

Please make to set the settings provided in last post and make sure of the following as well :

Allow DHCP server to set Time Zone : No

Advanced Settings :
Allow DHCP option 42 to override NTP server : No
NTP Server : us.pool.ntp.org (or other correct ntp server)

Update and reboot

When the base is rebooted an automatic call will be generated to update the time

BTW, which firmware you are using?

Best regards,
GSsupport


#5

Hi there,

Allow DHCP server to set Time Zone : No Check
Allow DHCP option 42 to override NTP server : No Check
NTP Server : uk.pool.ntp.org

When the base is rebooted an automatic call will be generated to update the time
Yes it does, but it still always shows the wrong time.

I upgraded the firmware to 1.0.0.8 from 1.0.0.5 because of this problem


#6

Hi,

This requires more troubleshooting, I suggest to open a ticket and we will follow up wit you.

Here is the link : http://www.grandstream.com/support/submit-a-ticket

On the other hand, the new coming firmware will be including DST settings by default in the standard time zones.

Best regards,
GSsupport


#7

You’re not going to believe this, but I’ve solved it.

I unplugged it from the mains, to move the base station to a different socket, lo and behold, it worked.

It seems a warm reset doesn’t quite reset as much as perhaps it should. :smiley:

I should have tried that earlier… Oh well, thanks for the help… sorry to waste your time.


#8

An update…

Since sorting this, I’ve discovered something.

The correct time ONLY displays after a cold boot. If the system is subsequently rebooted from the admin pages, the display time goes back to GMT.
Something to check and add to version 1.0.0.9 maybe :wink:


#9

Grrr!!! - It’s happened again.

This time the cold boot didn’t solve the problem.

doesn’t make any sense.


#10

NuIotaChi

The New upcoming firmware will include a fix, i can’t give any ETA when it will be released to the public, but it should be relatively close !


#11

I have the very same problem with the newest firmware release. Even cold restart doesn’t work.


#12

Just checking in on this post. I see it has been a moment, but I am having a similar issue with an HT818. This device is set to CST -6 , and shows the correct timezone on the ATA itself, but on the handset(s) connected to it - I get GMT/UTC time as described above in the OPs comments.


#13