GXW42xx DID assignment / SIP server


#1

I’m trying to figure out whether / how to configure a GXW4248 as a SIP server – using one account to register, and switching on incoming calls to route the DID to the proper port.

It doesn’t seem like this is possible – it seems like it can only be configured as a SIP device, with one account per port.

Is this true, or am I missing something? I can always create 48 different accounts and have them route from my provider’s end, but it is wasteful of REGISTER traffic.


#2

it is not a SIP server, but a FXS device. ]

It is a device that is intended to take a SIP message and then convert and route to an analog device. The message is generated from a SIP server to the GXW and is indeed expected to be a register account.

The same would be true if you had no PBX, but wanted 48 IP phones to register and use the signalling from the provider.

It is not a waste. just how it works in the scheme of using SIP.


#3

Okay, I understand.

But the problem is that I can’t route a DID to a specific port then. When I configure two ports with two different accounts (which have different incoming DIDs), it can’t tell the difference and rings on only one. The account isn’t part of the SIP message (just DNIS), so how does it know what port to use if there are only account identifiers in the configuration?


#4

Look at Port Settings->Advanced Port Settings->Request URI Routing ID. Configure each port with a DDI pattern and it will route the call to the device connected to the port if a match is found


#5

@rtl:

Thanks so much! I never would have figured that out.

Okay, so this thing will require separate accounts for each DID, I can deal with that I guess. Wish it could be configured as a switch, but so it goes.


#6

No, you don’t necessarily need separate accounts for each DDI. The SIP trunk delivers the call and the Request URI Routing ID rules route the call to the relevant port(s)


#7

Hmm, but how do I fill out the Port Settings then? Same account and password for each port? Then tune the registration interval down maybe to 1/48 of what it would be?


#8

If you’re GXW is standalone then you have a SIP profile that registers with your upline SIP registrar and handsets connected to the FXS ports. The FXS ports don’t need to register as there’s nothing to register with! You can still call one handset from another on the GXW but there’s no extensions…you just call by ports number


#9

Hmm, not exactly sure what you mean by “standalone”: It’s not connected to a PBX anywhere, I’m just trying to configure the 48 ports to work with 48 DIDs from my SIP provider. I can’t find anywhere in Profiles (or anywhere else) where I can register with an account and password – only in the individual Port configuration. As @lpneblett said, it acts like 48 ATA’s – not like a PBX.

I tried using the same account / password for two ports, and it’s not working – one number works, the other doesn’t. I suppose this could be because of my ITSP, but it definitely doesn’t work.


#10

Its not connected to a PBX so you use one of the 4 SIP profiles to register with your SIP provider. Connect FXS devices to the ports on the GXW and use the Request URI Routing ID rules.
The SIP profiles are on the Profiles menu…there are 4 profiles.


Have you read the GXW42xx manual at http://www.grandstream.com/sites/default/files/Resources/gxw42xx_usermanual_english.pdf


#11

Yes, I have the manual, and I’m using SIP Profile 1. But there is no registration user/password for the Profile, only the server name (see my screen shot). There is no registration user / password in the Basic Settings screen for the Profile either.

It seems there is no way to authenticate to the server except through the individual Port Settings.


#12

You have 1 trunk with multiple DOD ? This will not work.
Each port is SEPARATE device so you should have multiple accounts.
Multi trunk is for PBX not end devices.

You could buy extra UCM to make this working or ask provider to change trunk to multiple accounts.

Register is 4 packets long even x48 port it is less then 1 www page load :stuck_out_tongue:


#13

Thanks @marcin. It’s no problem having multiple accounts, they don’t cost me anything. Now that the actual routing is sorted out with Request URI, it will all work fine.

Thanks all!