GXW4232 Firmware will not upgrade


I have two GXW 4232’s that will randomly drop registration and won’t register again until they are rebooted. It has been a once every few months issue until this last week when they go offline every few hours. They are running which is super old, so I want to try to upgrade the firmware but they just won’t take an update. I’ve tried on local and remote http/https and on multiple tftp servers. When I set the device to tftp I don’t see any connection on the tftp servers at all, so I am doubtful they are even attempting to make a connection. Anyone have any ideas? I’ve tried openning a support request but email support never works out for me due to the volume of emails I receive on a daily basis.




#3 is the latest fw version for GXW V1 !!!
What version are you trying to upgrade/downgrade to?
Are the ports shown as registered when the issue appears but you cant make or receive calls?


Yeah that was the first thing I tried and didn’t do anything.


I’m trying to upgrade to, and on the gateway the extensions show as registered but can’t make any calls in or out, and on the system they show as unregistered.

#6 is for GXW V2 not V1 is the latest fw for GXW V1

Try to reduce the register expiration to 5 minutes

Is the gxw registred with remote or local SIP server?


They are registered to a local sip server


First thing to try is reduce the register expiration to 5 or 3 minutes
And set the unregister on reboot to Yes


find solution here: https://forums.grandstream.com/t/gxw4224-no-service-running/49861/3