GXW4108 Freepbx to HT701 (x2)


#1

The setup: 97 year old refinery with some bad phone cables (imagine that!) Client is moving to VoIP in the next 18 months. Looking to bypass bad lines with voip connections feeding through Asterisk to GXW4108. Current config on GXw4108 & FreePBX located here (pdf with screenshots) https://tinyurl.com/y8otmxnj

Configuation: Lucent Definity phone system from the very early 80s. About half a ton of soon to be junk. The Definity POTS extensions will be routed through the GXW4108 as needed to bypass bad phone lines. The network is ‘flat’, no routers/gateways. Consecutive IP addresses between all devices.

Inbound calls from the Definity through the GXW4108 work perfect. Disconnect works as expected. Outbound calls from the HT701 through Freepbx route to the GXW4108 and DO ring the proper extension on the Definity. However, there is NO ringback tone to the HT701 unless FreePBX generates it with Ttr or Tr options. Once the extension on the Definity is picked up, there is NO audio.

I’ve tried SIP and PJSIP connections, SIP has NO audio in either direction. PJSIP halfway works as above. I’ve tried PJSIP with no authentication and send authentication. Send most nearly works. Monitoring with pcapsipdump and wireshark shows inbound calls to FreePBX with RTP traffic working fine, but outbound calls to GXW4108 die after receiving a ‘501’ Not implemented msg to a REGISTER request. The userid and password that are sent from FreePBX are correct.

I’m about to pull my hair out…

Suggestions?


#2

I am a little confused with where you want the endgame to finish. The 4108 is an FXO device. It is typically used to take a number of POTS line and feed these to/from a IP-PBX as a SIP trunk(s).

It is not clear if the Definity is IP based and I am not clear on POTS extensions being routed through the GWX to bypass bad phone lines; what is a POTS extension?

You then go on to indicate that calls from the Definity thru the GXW work great, but then somehow or another a HT701 single port FXS ATA gets introduced into the mix with FPBX. Then FPBX somehow “route to the GXW and do ring…”.

Sorry, I am not following this scenario and while you can see, touch, live and breath it and know where you want to go with it, the scenario and description is confusing. Can you diagram it maybe with a narrative?


#3
  1. POTS = ‘plain old telephone set’, ie, AT&T 2500.
  2. The Definity is an ANCIENT phone system, from the era just beyond 25 pair cables to each phone for multiline systems.
  3. Client has a number of failing legacy phone cables in their complex (LARGE refinery, 97 years old). They are VERY reluctant to invest tens of thousands of dollars to replace these when the plan is to implement VoIP system wide within the next 18 months. The GXW4108-FreePBX-HT701 implementation is to bypass these bad phone lines via the fiber optic network that runs throughout the facility. In years past I’ve implemented ‘back to back’ single port fxo-fxs ATAs on a case by case basis with success. The idea in this case is to use the gateway to pass multiple (2 at this moment) FXO (single line station ports from the Definity) lines to the appropriate matching FXS ATA for that station port.

a.) Voice traffic from the Definity through the GXW4108 - FreePBX- the corresponding ATA works PERFECTLY.

b.) Traffic in the other direction hits the GXW4108, is picked up by the Definity and the appropriate extension does ring (without ringback to the ATA), but the connection dies after the GXW4108 rejects the call. The SIP session apparently stays connected until either end hangs up, then the call is terminated and the Definity line is cleared (available for reuse).

c.) In the Asterisk console on the FreePBX box I can enable PJSIP debugging and can clearly see the RTP packets being passed on a call from Definity to the GXW4108 through to the HT701. But when calling from the HT701 through the GXW4108, there is SIP traffic, proper authentication, and a rejection, and no RTP traffic. As RTP isn’t starting because of the rejection, one would think a NAT issue of some type, but the devices are on the same subnet, with no routers/gateways between them.

Does this clear the fog slightly?


#4

Yes this helps, the terminology used was incorrect which is why I asked -
Plain old telephone service ( POTS ) is an analog telephone service implemented over copper twisted pair wires and based on the Bell Telephone system.

As the ATA is connected to FPBX, it looks nothing different than a SIP extension as if it were a SIP Phone, which is what it is in this case.

Yes, you likely want to use PJSIP in FPBX.

Can you get a pcap of the messaging and post.?


#5

Pcap and log from asterisk command line (with pjsip debug enabled) located here: https://drive.google.com/open?id=1Ske_dGQrrHfyyJ1mhdHlXkI8nncZIW17


#6

I did not look at the good file, I did look at the bad pcap and there was only .02 seconds of a capture and it ended. There was not enough in it by which to understand what ma have happened