GXW4104 incoming call - no SIP invite?


#1

I have a brand new GXW4104 which I have attempted to set up with 3CX version 16.0.910. I was able to setup the SIP gateway fine, and make outgoing calls without issue, but I am unable to receive incoming calls. I set the gateway up according to this guide: https://www.3cx.com/voip-gateways/grandstream-fxo/ and also tried this guide: http://www.grandstream.com/sites/default/files/Resources/gxw410x_interop_3cx.pdf. I’ve tried many other things, but 3CX fails to detect any incoming calls. I have checked the 3CX activity log (set to verbose) and it shows nothing for an incoming call. The GXW4104 shows that the line status for an incoming call as “busy connected”. I set the syslog server up, and looking at the logs generated from the GXW4104, the FXO port detects the call, completes the CID and counts the rings, but it never sends a SIP INVITE to the 3CX server. At other times, I can see in the syslogs that the GXW4104 is registering with the 3CX server, yet 3CX does not detect an incoming call. Can anyone assist me with working out why no SIP INVITE is sent? Am I on the right track?
Thanks in advance.


#2

Hi All,

I am having the same problem as the OP which seems to have been solved and referred to by the OP at:

https://www.3cx.com/community/threads/grandstream-gxw4104-configuration-issues.66847/post-288399

I really need the same solution that is referred to in the above link, specifically the comment in relation to Grandstream providing the OP with “a firmware”.

Can someone from Grandstream help me please?

Or does anyone else have some thoughts / suggestions?

Thank you very much in advance.


#3

So, it would help to know what firmware version you are running in the device as neither you nor the 3CX post indicated same. The issue is that the last released firmware was quite some time ago (2013) implying that it is pretty stable.

What you can try is to disable callerID detection and see what happens.
You can then experiment with the PSTN ring delay pickup and adjust to 4 and see if the calls still flow. If so, then re-enable the caller-Id. If this does not work, then submit a ticket and reference the 3CX post, but state your observations of the issue as they are not apt to go ferreting through another manufacturer’s forum post in an effort to dig out the details.


#4

As @lpneblett mentions the 4104 fw is pretty stable and I’ve never had any issues with it on 3CX. You don’t mention which version of 3CX you’re using but the 4104 is ‘supported’ by 3CX at the current version (16.0.4.493) so you should be able to get help from your 3CX partner or 3CX direct
Make sure the 4104 is at fw 1.4.1.5


#5

Hi terrysydaus,

I raised a ticket with Grandstream support, and they provided me with a “custom” firmware (1.4.1.8). They can refer to my support ticket 20190720142431. They will only supply this firmware for people having this issue.

By the way, this “custom” firmware doesn’t work well with chrome (the pages are not displayed correctly).

I’m glad my posts are helping people with this issue.

Thanks,

jpoppi


#6

Hi Ipneblett,
I am running the latest released firmware (1.4.1.5) and am connecting it to my local IP-PBX (Raspbx) and everything is working except for the CID when I set the “Number of Rings Before Pickup” to a value greater than 2 at which time the calls stop flowing in. With it set to 2, the calls flow in but now caller ID.

I will do as you say before raising a ticket. May I ask how to disable the callerID detection in the GXW4104?

Thank you so much for your help.


#7

Thank you so much jpoppi.

This will be very helpful in the event that I have no success with the suggestion from Ipneblett.

Cheers. Terry


#8

Thank you rtl for your response.

I am not using 3CX. I am using the latest release of Raspbx (which includes Asterisk version 16.6.1 and FreePBX version 15.0.16.38).

With all your help I am sure that this will all be sorted soon.

Thank you so much everyone. Really appreciated.


#9

Hi Ipneblett
So I think I worked out how to disable callerID detection (by setting the Caller ID Transport Type to 2) and when I did this I could increase the Number of Rings Before Pickup to 4 and when I then made an incoming call, my phones rang displayed GXWT1 which corresponds to the Sip User ID / Authenticate ID of the GXW4104’s channel that the call is coming in on. It is not the phone number of the caller.

When I then re-enable the callerID detection (by setting the Caller ID Transport Type to 1), the calls no longer come through. Only when I reduce the Number of Rings Before Pickup back to 2 will the calls come through. However, when they do come through, the callerID is “Unknown”.

I believe strongly that I am experiencing the same problem as jpoppi as I too am in Australia.

So I do indeed need to submit a ticket. The problem here is that I registered 12 hours ago or so at (https://partnerconnect.grandstream.com) and I am still awaiting an email confirmation to have my account approved so that I can lodge a support ticket.
Should I have to wait this long in order to submit a ticket?


#10

Hi Ipneblett,
I am unable to raise a support ticket for this issue.
It looks like I need firmware version 1.4.1.8.
Can you please advise how I can get this version of the firmware?
Thanks in advance.


#11

As far as I’m aware its available only from GS support. You could try your local GS authorised partner or distributor if you’re a partner yourself


#12

That is developer version or pre- beta.


#13

Hi Marcin,
I need this version as it resolved the same problem with callerid that @jpoppi had and that I now have.
It fixed his problem, so I would like to use it to fix my problem.
Any ideas how I obtain it?
Thanks in advance.


#14

#15

Have you contacted the GS partner who you bought the unit from? Thats usually the place to start


#16

I am confused…you have one thread started and it contains a hang-up issue, which implies that in order to hang-up, it must have been engaged in call. In order to be engaged in a call, it must have sent an INVITE.

Can you explain?


#17

Hi Ipneblett.

There are 2 separate issues:

  1. The issue with the GXW not releasing the phone line quickly after the call has been answered and the caller hangs up.

  2. The incoming call does not display the caller id.

I am working both issues in parallel.

Hope that makes sense.


#18

Hi rtl,
Yes I have contacted the company that sold me the GXW requesting their assistance with the caller id problem and the potential fix involving the different firmware (1.4.1.8).


#19

Ah, OK, got it, thanks.


#20

I am using the following settings For my GXW410x and 3CX unit.

[Syntax: ch x-y: f1=val@vol,f2=val@vol,c=on1/off1-on2/off2-on3/off3; …]
Note: f1,f2-frequency(Hz); vol-volume(dB); c-cadence(10ms, 0-continuous)

Dial Tone: ch1-4:f1=413@-11,f2=438@-11,c=0/0;
Busy Tone: ch1-4:f1=425@-11,f2=375@-11,c=50/50;
AC Termination Impedance: ch1-4:10;
Number of Rings Before Pickup: ch1-4:5;
Caller ID Scheme: ch1-4:2;
Caller ID Transport Type: ch1-4:4; (you need to ensure that you have P-Asserted Identity - user part made active on Raspbian)