GXW-4104 won't upgrade to 1.4.1.5 [SOLVED]


#1

Hello,

I have a GXW-4104 gateway (actually two) with the following hardware and software versions:

Main-- 2.0 Rev A Part Number-- 966-00003-20A
Program–1.3.4.10 Loader–1.1.3.4 Boot–1.1.3.2

I have spent all day trying to upgrade it to 1.4.1.5, using both HTTP and TFTP. I need to upgrade it so it works with the latest version of 3CX.

In both cases I see it hits my HTTP and TFTP servers, but there’s an error. With HTTP it downloads the boot file (8KB) correctly, but only downloads 32 KB of the other two files. With TFTP it tries to download the boot and gxw4100 files, both with errors.

I found these two posts on these forums:


This is a GXW-4004 that would not upgrade until it was switched to a static IP. I tried both static and dynamic IPs, and nothing.


This one made it work by upgrading first to 1.3.4.13 before going all the way to 1.4.1.5, but I cannot find the 1.3.4.13 firmware anywhere. The GrandStream previous firmware page does not have anything for GXW-410x.


There’s also this one, but it suggest taking a small upgrade first and the link does not work. No comment on whether it worked.

So, can you help?

Thanks,

Luis


#2

I finally could find the intermediate upgrade version, 1.3.4.13. You can download it here:

http://malab.grandstream.com/firmware/GXW410x/1.3.4.13/

After upgrading first to 1.3.4.13, I was successful in upgrading to 1.4.1.5.

So, problem solved!

Best,

Luis


#3