GXV3380 fails to filter blank spaces from Google contacts

bug

#1

I recently added a new GXV3380 to my telephony network of 2 x GXV3275. After applying the right configuration to work with my environment, the phone mainly does what it’s supposed to do.
I just found an issue with contact phone numbers stored in the phonebook synched with my Google account. Google automatically adds some blank spaces between group of digits (the contact app of the GXV3380 does it too when adding a new number there). This is no problem with the GXV3275 as these phones filter out the blank spaces automatically when dialing from Google synched phonebook. But the GXV3380 does it not and therefore fails to dial those numbers.
I tried to add a space character in Web GUI under Phone Settings – Call Settings – Filter Characters -> [()- ], but it has no effect. I played around with the filter function and learned that it works correctly for the other characters. Brackets and hyphens are filtered when dialing from phonebook as long as they are present in Web Gui Filter Character setting.
In another forum I read that Google uses no-break spaces within phone numbers. Unfortunately I haven’t managed to add a no-break space to the setting. When copying such a character from another Windows application (e. g. MS Word or character map), only a “normal” space is added to the Filter Characters setting. It’s also not possible to use the HTML code   nor the hexadecimal or decimal value.
Deleting the spaces from the phonebook phone numbers manually would technically be a possible workaround, but practically it’s not a real option due to the manual work. As a user I would also need to regularely delete the spaces if adding new numbers.

I suppose it won’t be a big deal for Grandstream to fix this and hope that they include a fix in the next firmware version (already opened a ticket on this topic).

Has anyone a good idea / workaround for the meantime other than manually editing all phone numbers in my phonebook?