GXV3240 loop reboot after update firmware


#1

Hello,

I started updating my GXV3240 via my UCM6208.
Everything went well except for one that now restarts in a loop.
I tried to do a reset (via 1 and 9) or an update via the SD card (with * and #) but nothing works.
Is there a solution other than these to try to recover it?

Thank you in advance !


#2

Loop is often by config files. Try checking settings on UCM.


#3

Hello,

Thank you for your reply !

I do not have a particular parameter for this phone (or for others, which work them however after the update of the firmware).

I still tried to connect it to the mains supply, disconnected from the network (POE) and the symptoms remain the same.

I went through the forum and tried to put the firmware on an SD card (SDHC 4GB) directly on it, or to “burn” the image via an application but not better.

Is there a “hard reset” other than the keys 1 + 9 or manipulation to boot it in safemode?

Thank you in advance :wink:


#4

Have you tried booting up without Network Connectivity.


#5

Good evening! Yes as stated in the previous message: D
Here are its different phases:

  • It starts with the led lit in green, then it turns off after a few seconds.
  • The screen remains frozen with the “Grandstream” logo
  • Then after a few more seconds, it goes out and starts again.

#6

Try upgrade with SD card (check manual). It loo more like damaged firmware now.


#7

Is there a special procedure?
I have already tested to put the firmware on a sd card and nothing makes it.


#8

Yes you need push buttons correctly, check manual for exact procedure.


#9

It was really hard to properly press two keys at once, thank you for your support …

In short … I tried this procedure (in the manual) :

Insert the SD card to the GXV3240. The SD card should have the valid firmware bin file in it. Power
cycle the phone and the MWI LED will light up. Wait until the MWI LED lights off. Then immediately
press both “*” and “3” keys at the same time for about 8 seconds. MWI LED Release the keys
lights up again. The phone will start the upgrading process.
Note: Before upgrading, please ensure your device is using a 12V power adapter.

It works on one of my other phone but not the one impacted by the problem.

Is there another “fail safe” procedure or solution via tftp?

I have read the manual and I do not see any procedure of this kind.

Thank you in advance to the people who will provide a constructive response :slight_smile:


#10

If you have problem with this then go to GS helpdesk https://helpdesk.grandstream.com.
SD card is best available way to do it normally. Other means are not so easy:
DHCP option 66, SSH to phone and set upgrade, catching packets and build lab to simulate environment for proper upgrade. But all depend how phone react at start. We need a lot more information for helping.


#11

Ok so :slight_smile:

Nothing on the network with wireshark with the mac of the phone
Nothing coming with tftp service on the network to


#12

Helpdesk, maybe GS can help you more.