GXP2170 - Second call goes to voicemail


#1

We’re testing this internally without issue. If on the line and a second call comes in, incoming call screen appears and we can answer. For a client however, if a second call comes in it will go straight to voicemail so there must be something I’ve configured incorrectly in the device template through GDMS. I’ve uploaded our device configuration if anyone is able to assist.

GXP2170.xml.zip (1.5 KB)
Service provider: voip.ms

EDIT: I have followed the steps from this thread but no fix. https://forums.grandstream.com/t/gxp2170-how-to-display-a-second-incoming-call-on-screen/33732

SOLVED: Account -> Call Settings -> Enable Call Waiting

I changed this to Yes, it needs to be set to Default.


#2

If the phone handle two calls, then the issue is likely not the phone, but the routing. When a call comes in, where does it go…ring group, queue, extension?


#3

It goes to a ring group but I have verified it is not that. I exported the custom config from GDMS, imported it to my phone and now my phone has the same issue so I’m on the right track. Going to edit each option one by one until I find the culprit.


#4

If a ring group, look for skip busy agent and if enabled, disable it. That will allow a second call.


#5

Solved.

Account -> Call Settings -> Enable Call Waiting

I changed this to Yes, it needs to be set to Default.


#6

I think this is what @lpneblett was referring to when mentioning

And also, if someone has a similar issue that has not been resolved with the call waiting option, check the line/account configurations (Line keys, VPKs) if set to line or account mode.