GXP2170 No Outbound Calling after Firmware Update


#1

Hey guys and gals… I have GXP2170 that was upgraded to 1.0.9.121 and configured to phone on my freepbx distro. The phone registers and the pbx says the phone is reachable. When I try to dial out for that extension the phone errors out and gives and “No Response” and a fast busy tone. I’ve tried rolling the firmware back and factory resetting multiple times. I’m stuck here… Does anyone have any ideas on what could be causing this?

Note: This is a fresh install of freepbx as I though the problem was the pbx at first. Softphone is working as it should.

Thanks

-Mike


#2

Hi Mike,

Is your peer configured to use sip or pjsip?
Pls go to asterisk cli, type the following commands and copy the output back here for further assistance (replace XXX with the sip extension of your gxp2170):

sip show peer <XXX>

after that, type:

core set verbose 3

now place a call with your gxp2170 and copy all the verbose output back here.

regards,
yves


#3

I’m using pjsip extensions. Should I run pjsip show endpoints instead of sip show peers?

Mike


#4

yes, that would be the appropriate command if you´re using pjsip…

Y.


#5

Hi and happy new year!

so… to avoid question-loops, please add the answers / output to your answer:

1.) are you using pjsip exclusively or mixed with SIP? Do you have more than 1 account configured on the phone?
2.) whats the cli output of pjsip show endpoints
3.) whats the cli output of pjsip show endpoint XXX (where XXX is the problemativ extension from your gxp2170)
4.) whats the cli output of pjsip show transports
5.) whats the IP of your asterisk
6.) what did you enter in the Configuration-gui of your grandstream in the field “SIP Server” of account 1
7.) Did you make any changes on the gxp2170 configuration except the account-data?
8.) set verbose to 3 and wait (or force by phone reboot e.g.) until phone registers… whats the output? Do you see fail or success logmessages?
9.) Place a call with the GXP2170 and paste the output from the cli.

TY
Y.


#6

Hello everyone,

I was able to solve this issue this morning. I had thought that this was was broken by the firmware update. It so happens that the local calling features on this phone were enabled. I had dialed *30 from the phone and it enabled the “disable caller ID feature” on the phone. I was trying to use *30 to dial by PBX’s blacklist feature code. Subsequently this enabled the “send anonymous” feature toggle in the phone’s GUI and the phone was sending anonymous sip headers the PBX. The PBX was refusing anonymous contacts and rejecting the outgoing calls only.

Everytime I factory reset it was in fact resetting to default settings and when we tried the dial the blacklist feature code it was being enabled again thus making dme pull my hair out.

I very much appreciate the feedback and responses I received and thanks to this forum for helping solve this problem.

Thanks

-Mike