GXP2170, how to display a second incoming call on screen


#1

Hi

I am guessing this is a P-Code or an option in the UCM somewhere…

When a 2170 is in use (incoming call) and another arrives (say from a ring group) the phone will show a small box at the base like the image below… how is this feature enabled? (i have at least one site this doesnt work on)


#2

I thought that was added in firmware about 1.5 to 2 years ago. Are the phone on old firmware?


#3

Phones were on 69, now on 121, still not doing it, they have never done it…


#4

Odd. I’ve never added a pcode to enable. Any chance a pcode has been added to remove?

I’d experiment by removing any zero config templates, backing up the config, factory reset with just the extension info on the phone and test.

Or… you know… Wait for someone who knows :(:smiley:


#5

My phones “just did it”, i have a site that doesnt.

Resets, reloads, restores are normally an “overfix” and introudee new problems.

I have however enabled “call features” in the UCM (which wasnt enabled), to see if that does it. Ive also opened a ticket with Grandstream.

Worth noting this site is using real old lines, mine are VoIP, i would assume this makes no difference but, never know.


#6

According to grandstream the UCM doesnt support call waiting on the deskphone when analog lines are used in to the UCM PBX !!!

Doesnt seem to make any sense to me… but thats what support says!


#7

This is phone feature.
P8391 1 (0 off)

Settings -> call featurs
image


#8

Hi

I agree i think this is a phone feature, however Grandstream say otherwise… Ive tested this as not working on the site, see below, so at the moment when phone (or the UCM) is not routing the call to the phone (this still may be a UCM configuration issue).

The below phones are all in the same UICM (firmware
Phone A calls Phone B (active call)
Phone C calls Phone A, Phone C hears Phones A voicemail, why is the UCM doing this? clearly it didnt send the call to Phone A in the first place as it saw it was on the phone…

The setting you show above is already set to YES in the phone in question, however Allow incommig call before ruining is set to no.

What in the UCM is not sending calls to the phone when its in use?

My UCM works as designed, it calls the phone even if the phone is in use, is this by design or is that a bug? clearly speaking shouldnt the UCM route a call to voice mail BUSY if the extension is in use (my system doesnt unless i reject the second call).


#9

That’s other problem, windows you post is from that settings, but blocked call is from:
Call waiting - it both phone and UCM.

UCM extension

Phone general

Phone account


#10

Call Waiting in every extension in the UCM is on.

Grandstream have verified the phone config (i sent it to them) is working ok, so they now think its a UCM issue.


#11

It can be ucm bug for sure, if packet trace do not show sending 2 invite to phone then must be UCM.

Try disable call waiting and then enable it again in UCM extension. Maybe setting is set no and show yes (or reverse).


#12

I think i have gotten to the bottom of this with Grandstreams help… turns out a REAL ODD reason.

GXP2135 / 2170 (likely the same for the other GXP21xx but not tested it)

  • The phone is in the default LINE MODE (GUI > Settings > Programmable Keys > Virtual Multi-Purpose Keys Settings > Key Mode = LINE MODE
    AND
  • All buttons are assigned (BLF, Account, ANYTHING) (8 for the GXP2135, 12 for the GXP2170)
  • THEN call waiting will NEVER show on screen, no matter what the phone settings are to allow it

If all the screen buttons are used then the phone must be in ACCOUNT mode for the call waiting to show up.

Key Mode P-Code is P8369 (2 = Account)


#13

That is weird, thanks for sharing.


#14

Yep, borderline bug if you ask me… there reasoning is this…

LINE MODE = Only 1 line (voice call) per button
ACCOUNT MODE = Any number of calls per buttons

Logisticly it makes sense (and i confirmed it here), my GXP2170 has 1 spare button left (12), in LINE MODE i get call waiting, if i then assign ANY BLF to button 12, call waiting doesnt work, goes right to voicemail.

When button 12 is free (nothing assigned), it doesnt show up when call waiting is doing its thing, so really this is an internal bug in the phone, i think ALL phones should be “ACCOUNT” mode, whats the point of having a LINE mode ??? its just limits the calls the phone can do…

Ive spent 4+ weeks on this and one real unhappy customer who has a reception who can only ever get 1 call at a time (until yesterday morning).


#15

Other hand it is know. LINE = must have 2 for attended transfer too, it is same logic for call wait i guess.