GXP2170 Dial plan for 7-digit dialing **why doesn't this work?!**


#1

I know that this is covered on these forums and around the internet, but I have had ZERO luck making this work. I have a need for 7-digit and 10-digit dialing on my gxp2170, but no matter how i format the dial plan in the the XML file if “<=941>” or “<=1941>” is in the dial plan the phone does not accept the configuration file. I can watch the access.log when it is pulling the config and if the config is accepted and applied it only pulls one file, if it is not accepted then it pulls several files, great indicator. I have tried using P66 but this prepends the area code to ALL calls, even if there is already 10-11 digits, so that can’t be the right setting. is there something in the new 1.0.9.69 firmware that broke dial plans? another note is that i CAN make it work by using the web GUI, but my application requires remote provisioning with my provisioning server setup. I have also tried copying the dial plan out of a config file pulled from the phone after configuring the dial plan via the GUI but that exact dial plan is still not accepted when remote provisioned. I have also contacted grandstream support about this and they claimed it worked for them, repeatedly, until i gave up on them, useless. any insight?

I have tried:
{’+x+ | *x+ | xxx+ | <=1941>xxxxxxx+}
{’+x+ | *x+ | xxx+ | <=1941>xxxxxx+}
{’+x+ | *x+ | xxx+ | <=1941>xxxxxxx.}
{’+x+ | *x+ | xxx+ | <=1941>[2-9]xxxxxx}
{’+x+ | *x+ | xxx+ | <=1941>[2-9]xxxxxx+}

I am at the end of my rope!


#2

The newest firmware is 1.0.9.108 which is more than one past where you’re at.


#3

I have now updated the firmware to the newest 1.0.9.108 version. but testing shows that, still, any time there is a prepend(<=941>) function in the dial plan for account 1, the provisioning fails. remove that part of the dial plan and the same config file succeeds. I did try many variants of the dial plan as i had on 1.0.9.69.


#4

XML doesn’t like < or > in fields, since it’s a separator. LMGFY shows http://xml.silmaril.ie/specials.html and says that you should use < and > for < and >


#5

{’+
is there really ’ inside ?


#6

Yes, the -’- is really there, it does differ from what the config template says is default, but the dial plan works with that in there so i saw no need to change it. The tests have the same result with and without that apostrophe. Smartvox, i am going to test your idea now


#7

In theory, things which do not match dial plan characters are ignored, so the ’ is irrelevant and can be removed or left in if it makes your life easier.


#8

Smartvox, thank you so much! so the “less than” and “greater than” symbols, being special characters in XML were making the XML file invalid when typed in as normal, i had to use “lt” and “gt” in between an ampersand and a semi-colon to represent the < and > everything works great now! Grandstream, this would be a helpful note in the dial plan documentation “NOTE: to use prepend and postpend in dial plan special characters must be used for “<” and “>”” there, I wrote it and i give permission for you to use that statement in the docs.


#9

Yup, just like I wrote. :slight_smile: Glad to help. Feel free to like my reply! :slight_smile:


#10

I liked it the very moment that I successfully dialed 7 digits and the area code was added!


#11

Hahah! :slight_smile: It’s kind of a joke because we think that “likes” are useless yet we somehow are leading the most “liked” here.

Seriously, glad it’s working.