GXP2160 not starting, unable to do an firmware update


#1

One GXP2160 is not starting up, there is just the progress bar on the screen.
I have tried to update the firmware via ssh, but with no effort.

The most error message via ssh is:
Failed to open connection to “session” message bus: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

Phone Status:

Product Model: GXP2160
P/N: 9620005115A
MAC Address: xxx
Network:
IP Address – 192.168.178.59
Netmask – 255.255.255.0
Gateway – 192.168.178.1
DNS Server – 0.0.0.0
DNS Server – 192.168.178.1
Software Versions:
Prog – unknown
Boot – 1.0.1.2
Core – 1.0.4.5
Base – 1.0.4.18
System uptime: 354
System load: 0.17, 0.20, 0.12
Memory Usage: 251506688/202067968/0/6868992


#2

I am not sure about the sequence of events, The post does not indicate if the phone using the then installed firmware just started to exhibit the issue or if some other action beforehand, such as an attempted firmware update surfaces the problem.

If an update was attempted then perhaps it was too much of a jump (see number 2):
Note:

  1. Firmware marked with ***** is released with limited bug fixes and feature implementation, please read release notes for more information.

2. IMPORTANT UPGRADING NOTES:

- If the GXP21xx phone is on firmware 1.0.4.x or lower versions, please upgrade to 1.0.7.97 first.

The HTTP upgrading path for firmware 1.0.7.97 is:

http://firmware.grandstream.com/gxp21xx/1_0_7_97

Here are the links to download 1.0.7.97 firmware packages:

http://firmware.grandstream.com/Release_GXP2130_1.0.7.97.zipstrong text.


#3

You can try booting without a network connection and see if that makes a difference.


#4

There is no hint of upgrading. After giving the command upgrade and typing “y” the ssh connection breaks.
But nothing else happens.

When I connect again via ssh, there is still the same version.

I also have tried to upgrade via tftp and the 1.0.7.97 but without effect.


#5

Did you try @lstutesman 's request to start without internet? Still needs to be connected to a router for DHCP but nothing connected to the wan.


#6

Yes have tested it, without effect


#7

You might try and re-install the older version of firmware you were running originally. It is just a thought as perhaps the other firmware partitions work in conjunction with what the phone currently has loaded (core, boot, etc.). The hope is that it will go back to its original state whereupon you can then follow the upgrade path,

If this does not work, I can only suggest submitting a support ticket with GS.


#8

I have tried to install an older version or a newer one. It does not help. When I start the upgrade the phone cances the ssh session directly and nothing happens.
I already have opened a ticket with the gs support and hope to get help from there.

Thanks for the hints here.


#9

This is broken fw.
Connect phone directly to your PC and sniff packets (whireshark). If phone ask for upgarde (IP) or try DNS with firmware name then you can save it. If it use DHCP then it even easier :slight_smile:

TFTPD is DHCP/TFTP/DNS server which you can use to allow phone to “upgrade” firmware for fix. You will need 1.0.5.x or 1.0.4.x firmware for this.You can try .0.7.x which is on GS page, maybe it also work.

How:
DHCP option 66 is best (if not off on phone)
If not you will need create correct network environment so phone can upload firmware from your PC.
I really cannot say more without sniffed packets.


#10

I have set up the environment you said. But the phone is still disconnecting, when starting the upgrade.
Factory reset just brings the error message as before.
.
I also have installed the Wireshark, but don’t know what to do in this tool.


#11

just start collecting packets it then plug in phone