GXP2160 intermittent issue where it can't answer the call, other phones still ring


#11

Not the original poster, but none the less. Here is a screengrab of what the phone is sending in my situation

.

The two on the left were failed calls, where the receptionist couldn’t pick up. The one on the right is a call that worked normally.

For whatever reason the phone is not sending a 200 OK to answer the call (but it is OKing the CANCEL after 15 seconds (which is what the ring group timeout is set to)

The phone won’t answer regardless if it is attempted via the headset, handset, or line key directly


#12

Not the solution but a possible work around.

Set all the phone in the ring group into a Pickup Group. Program another button on the phone (hopefully you have one) with a speed dial *8 to pick up any ringing call in the pickup group.

It dosen’t fix the issue but, it gives the person the chance to answer the call.

This works for the UCM, I’m not sure about other PBX’s.


#13

Mkras, We seem to have the same issue judging by the wireshark. My captures read like the user never picked up the phone.

For now, I have swapped out the receptionist’s GXP 2160 with another GXP 2160 that shipped out with software version 1.09.69 and it has been stable and no call issues for 5 days now. I am going to leave it on that version until I can figure out if this is a version issue or hardware issue or network issue.

When I have time, I am going to take her old phone to my lab and try to reproduce this issue by calling it over and over with a webcam recording the phone’s screen and capturing traffic and syslog from the phone and hopefully prove this problem exists.


#14

@costwisewpg Thanks for the idea. That definitely seems like it would work, however this is happening when receiving transferred calls as well. Which would be much messier to implement with a pickup group. We’re on a hosted asterisk-based platform.

In the interim, I’ll likely just have to deploy some Polycoms on some of the key-desks.


#15

@shaunkrug, I’m glad I’m not the only one experiencing this. I plan to do the same thing to test thoroughly. I’ll let you know if I make any progress. I’ve also got a ticket open with support, so we’ll see what they can find.


#16

I have a customer with 2170’s and the same issue. One or two of them send me emails saying that when their phone is ringing they will go to answer it and they hear dial tone. We upgraded their firmware on all of their phones to 1.0.9.127 and the issue still happens.


#17

We are seeing this EXACT issue with 2 2170’s. We went nuclear-- factory reset, upgraded to 1.0.9.121, moved from a hosted FreePBX 13/Asterisk 13/chan_sip system to an on-premise, FreePBX 14/Asterisk 16/pjsip system. New system built from the ground up, not copied anything over. Problem persists. Same symptoms.


#18

Catch packets.
And try enable this option. Maybe it is not a call.
One should be enough to prevent ghost calls.


#19

I have one client who complained about a similar issue. 2160 .121/127 F/W

The complaint was that while in a call and another one comes in, she can’t hang-up the 1st call to answer the second. Well, this is odd, so I then informed that hanging up was not necessary and that simply answering the 2nd would place the 1st on-hold. That’s when she indicated she could not answer the first. Her co-worker indicated that he too had the issue, but that it had not re-occurred since he starting manually rebooting his phone every Monday AM as a matter of practice and not knowing what else to do. This is what I think she is now doing and no issues reported since.

Not suggesting that is a solution by any means as it should not need to be rebooted to restore functionality. I wanted to file a ticket on it, but I knew that GS would want info and testing to try and simulate the issue, but the client is in Missouri and I am in Texas and their IT folks are somewhat less than easy to work with.

The trace shown earlier shows no indication of answering which does not mean that the attempt was not made. As there are several methods of answering, I wonder if each has the same result -

  1. Using the answer key on the display
  2. Picking up the handset when ringing
  3. Using the speakerphone button while leaving the handset on-hook
  4. Checking the EHS and headset settings.

I have no one else complaining, but then perhaps they are happy about someone else getting the calls.

If you are in a position to submit a ticket, please, feel free.


#20
  1. Using the answer key on the display
  2. Picking up the handset when ringing
  3. Using the speakerphone button while leaving the handset on-hook
  4. Checking the EHS and headset settings.

We tried all of those, same results.

Our traces show that the phone never sends an OK/answer packet back to the PBX. This a client that gets 100-200 calls and it happens on about 10% of them. They are legitimate callers because someone else in the RG is able to answer.


#21

What firmware?


#22

In our situation, it only happens on phones that have been upgraded to 1.0.9.*** (all minor versions).

No issues on any phones running 1.0.7 or 1.0.8. We’ve had phones with the issue running 1.0.9, and once we downgrade them the issue goes away.

The weird part is that as a temporary fix, I installed 8 new phones that shipped from the factory running 1.0.9.108, and none of them have had any issues. I’m not sure if something with the upgrade process is going wonky, but definitely something weird.


#23

.x is not telling me which version as there was 102, 108, 121, 127 and 132. 108 was removed from circulation as it had an issue with codec negotiation. Most of the reports I have see have involved the 12X versions, but as AFAIK, those that upgraded to .132 have not reported it since. While I cannot say that this is a definite fix, I can only say the absence of any reports is promising.


#24

The only “bugfix” I see in the .132 release notes are below, and I can’t say that anything quite matches the reported problems (that we are sharing here on a single GXP2140 device). Anyone?

BUG FIX
• Fixed No audio issue with call pickup answering
• Fixed One-way audio issue after picking up monitored BLF call if caller is using certain audio codecs
• Fixed No audio issue after RE-INVITE
• Fixed Device does not send PRACK in ALLOW header when sending 180 Ringing
• Fixed Phone replies with 200OK “sendrecv” upon receiving INVITE “sendonly” for SIP/UDP and
SIP/TLS with Broadsoft
• Fixed Phone displays N/A on screen if weather service is unavailable
• Fixed Broadsoft UC-One: Not reusing authorization header for XSI
• Fixed Broadsoft UC-One: Dialing conference with ID and PIN have DTMF issue for IM&P
• Fixed Security vulnerability issues


#25

I agree, nothing mentioned that indicates the issue or a fix. I can only indicate what my experience was as well as others.

I assume that just as they may unknowingly break something with a new version, they may also unknowingly fix something as well. I also assume that the possibility exists that not every problem or fix may be reported.


#26

Updating this phone to the 1.0.9.132 on this phone has not cured the problem for my client. Calls continue to come in that they cannot answer.
I managed to locate a copy of 1.0.8.56 for the GXP2140 device. I don’t know if putting that in will help at all or make things worse.


#27

Hello @thepossum

I have copies of firmware for 1.0.7.99, 1.0.8.36, and 1.0.8.44 if you want them. Not sure they’ll help but, I’ve got 'em if you want 'em.

Regards,


#28

The firmware.grandstream.com website doesn’t link to them any more, but .zip files with previous versions are still available for download:
1.0.8.47 1.0.8.50 1.0.8.53 10.0.8.56

I don’t actually have a full list of what versions were released, so can’t say if there are any earlier or later without attempting to download it manually. I am unable to pull down the .36 or .44 versions you mention.


#29

I think that if firmware were the issue and as you have experienced it on numerous versions, there would hundreds if not thousands complaining.

I suggest you do a capture of a call if possible.

BTW, are you the same as mkras who posted earlier?


#30

I can’t do packet captures, I’m working remotely from an entirely different subnet/lan.

The office is a new installation, with a hosted freepbx 14. All the other phones are GXP2130 with 1.0.9.127 and not experiencing this issue. The receptionist has a GXP2140 with some sidepanel extension boards, and this is the single phone that is intermittently unable to answer calls. Call comes in, everything on the phone is blinking and alerting, and neither picking up the handset nor using the speakerphone button will answer the call.

We’d set it up with the then-latest 1.0.9.127, and even after upgrading to 1.0.9.132 it’s still experiencing the same problem. I’ve currently got 1.0.8.56 on it and can now only wait for feedback from the client.

Possibly my only other recourse right now, if the complaints continue, is to repurpose the one GXP2140 in our own office, which I’m told has some relatively ancient 1.0.5.x firmware version.