GXP2160 intermittent issue where it can't answer the call, other phones still ring


#1

Hi there,

I have an unknown issue in two different PBX deployments with a GXP 2160 not answering an incoming call. When the handset is picked up to answer the call, the GXP2160 will show the Dialing menu instead and quit ringing. Other phones on the ring group will continue to ring until the incoming call is answered. This issue occurs on a single GXP2160 in each of my deployments anywhere from 0-2 times per day with an average of 100-200 incoming calls daily.

In both deployments, it is a specific GXP2160 unit that has this issue. There are several other GXP2160 phones in the same deployment that do not have this issue. I have not seen any evidence in a packet capture, captures always show another extension answered the call, but no messages from the GXP2160 during the answering of the call when the issue happens…

I am on the latest firmware. Thanks for any help!

Software Version

Boot 1.0.7.3

Core 1.0.9.93

Base 1.0.9.106

Prog 1.0.9.127

Locale 1.0.9.114

Recovery 1.0.9.96


#2

Did you create groups or what? How did you create them etc.?


#3

I am using Freepbx 14.

In Freepbx I have about 5 extensions in a ring group for the main incoming line. Traditionally whoever answers first gets the call.The user with the GXP 2160 attempts to answer first, but instead the GXP 2160 shows the dial menu where you would place a call.
The call continues to ring the other phones.


#4

Will need a capture of this to see the signaling and timing. Does the same ever occur when the extension is dialed directly?


#5

Hi, I have been waiting for the receptionist to let me know when this issue happened. It finally happened again. Unfortunately there is still no evidence here to show that she tried to pick up her phone. I can provide the full asterisk log of the call if you think that might help.

So in this call, 192.168.22.1 is Freepbx server, and 192.168.22.105 is the GXP2160 with the issue:

|4072|10010.015100|192.168.22.1|192.168.22.105|SIP/SDP|1135|Request: INVITE sip:105@192.168.22.105:5060 | |
|4073|10010.036733|192.168.22.105|192.168.22.1|SIP|544|Status: 100 Trying | |
|4074|10010.047067|192.168.22.105|192.168.22.1|SIP|626|Status: 180 Ringing | |
|4091|10021.275446|192.168.22.1|192.168.22.105|SIP|534|Request: CANCEL sip:105@192.168.22.105:5060 | |
|4096|10021.318711|192.168.22.105|192.168.22.1|SIP|595|Status: 200 OK | |
|4097|10021.335752|192.168.22.105|192.168.22.1|SIP|571|Status: 487 Request Terminated | |
|4098|10021.337135|192.168.22.1|192.168.22.105|SIP|464|Request: ACK sip:105@192.168.22.105:5060 ||

What I see above is that the GXP never answers the call. It goes on to be answered by another extension.

Thanks for your help!

Edit: I forgot to mention that the capture is being done by the GXP2160 with the issue. I am capturing to USB drive.


#6

I sent you email.


#7

We’re encountering a similar issue with one of our clients this week. This particular office has 25 GXP2140/60s, and 40 Yealink T26s. Only 4 of the grandstream phones (2x 2140s, and 2x 2160s) are having the issue. All the phones are on firmware 1.0.9.127

Some other notes;
-None of the yealinks are having the problem.
-Hosted Asterisk server.
-Similar to you, the pcaps don’t show any evidence of the phones attempting to pickup the call. Happens intermittently.
-Downgrading the firmware isn’t an option, as we need the phones on 1.0.9 to utilize new dial plan rules, (“T”)

If you manage to figure out what might be causing this, I’d definitely be interested to know. We’ve tried everything to straighten these out, but haven’t had any luck yet.


#8

It shows that the phone responded back to the PBX indicating that it was ringing. The CANCEL is when the PBX told the phone to quit ringing as someone else answered.

So, we know the phone is messaging correctly, it also OK’ed the CANCEL.

This leaves us with the following options:

  1. It is indeed ringing per the message and the ringer volume is turned down on the front panel of the phone or it is set to ring the headset and not the speaker.
  2. Presumably there is a line button on the display when a call comes in. When it does come in does the line/account button blink or light up indicating a call?
  3. When a call is made from the phone, does the line button light up?

#9

Good questions.

I went over with the receptionist last month about checking that the handset is properly seated. I thought this was her issue at first. I thought she didnt realize, like you said, that the phone might be unintentionally going to speaker. Both her and the coworkers that sit by her are telling me these details about when a call comes in on this phone:

When a call is incoming on her phone, the 2160 flashes on her line and the screen shows that there is an incoming call. Of course the 5 BLF lights for the other extensions are blinking as well. She picks up the handset to answer the call. The incoming call screen goes away, and the “dialing screen” (the screen you get when you pick up the handset to make a call) comes on and her line light quits blinking. The BLFs continue to flash until someone else answers the call. It is like her phone goes to the wrong menu and gets ready for her to dial a phone number instead of answering the call that is ringing.

Does this help you visualise the issue? I mean this only happens every 1 out of 100 calls that she answers, but she is the primary person that is supposed to be answering the calls, so they get frustrated when this issue comes up and someone else has to answer.


#10

I get the picture,
Can you do a wireshark capture at the phone and post? I know it may be a pain given the randomness.
If she presses the line key while the handset is on-hook, does it always answer then? It will go to speakerphone, but curious is the press of the button forces the issue that lifting the handset (off-hook) does not.


#11

Not the original poster, but none the less. Here is a screengrab of what the phone is sending in my situation

.

The two on the left were failed calls, where the receptionist couldn’t pick up. The one on the right is a call that worked normally.

For whatever reason the phone is not sending a 200 OK to answer the call (but it is OKing the CANCEL after 15 seconds (which is what the ring group timeout is set to)

The phone won’t answer regardless if it is attempted via the headset, handset, or line key directly


#12

Not the solution but a possible work around.

Set all the phone in the ring group into a Pickup Group. Program another button on the phone (hopefully you have one) with a speed dial *8 to pick up any ringing call in the pickup group.

It dosen’t fix the issue but, it gives the person the chance to answer the call.

This works for the UCM, I’m not sure about other PBX’s.


#13

Mkras, We seem to have the same issue judging by the wireshark. My captures read like the user never picked up the phone.

For now, I have swapped out the receptionist’s GXP 2160 with another GXP 2160 that shipped out with software version 1.09.69 and it has been stable and no call issues for 5 days now. I am going to leave it on that version until I can figure out if this is a version issue or hardware issue or network issue.

When I have time, I am going to take her old phone to my lab and try to reproduce this issue by calling it over and over with a webcam recording the phone’s screen and capturing traffic and syslog from the phone and hopefully prove this problem exists.


#14

@costwisewpg Thanks for the idea. That definitely seems like it would work, however this is happening when receiving transferred calls as well. Which would be much messier to implement with a pickup group. We’re on a hosted asterisk-based platform.

In the interim, I’ll likely just have to deploy some Polycoms on some of the key-desks.


#15

@shaunkrug, I’m glad I’m not the only one experiencing this. I plan to do the same thing to test thoroughly. I’ll let you know if I make any progress. I’ve also got a ticket open with support, so we’ll see what they can find.


#16

I have a customer with 2170’s and the same issue. One or two of them send me emails saying that when their phone is ringing they will go to answer it and they hear dial tone. We upgraded their firmware on all of their phones to 1.0.9.127 and the issue still happens.


#17

We are seeing this EXACT issue with 2 2170’s. We went nuclear-- factory reset, upgraded to 1.0.9.121, moved from a hosted FreePBX 13/Asterisk 13/chan_sip system to an on-premise, FreePBX 14/Asterisk 16/pjsip system. New system built from the ground up, not copied anything over. Problem persists. Same symptoms.


#18

Catch packets.
And try enable this option. Maybe it is not a call.
One should be enough to prevent ghost calls.


#19

I have one client who complained about a similar issue. 2160 .121/127 F/W

The complaint was that while in a call and another one comes in, she can’t hang-up the 1st call to answer the second. Well, this is odd, so I then informed that hanging up was not necessary and that simply answering the 2nd would place the 1st on-hold. That’s when she indicated she could not answer the first. Her co-worker indicated that he too had the issue, but that it had not re-occurred since he starting manually rebooting his phone every Monday AM as a matter of practice and not knowing what else to do. This is what I think she is now doing and no issues reported since.

Not suggesting that is a solution by any means as it should not need to be rebooted to restore functionality. I wanted to file a ticket on it, but I knew that GS would want info and testing to try and simulate the issue, but the client is in Missouri and I am in Texas and their IT folks are somewhat less than easy to work with.

The trace shown earlier shows no indication of answering which does not mean that the attempt was not made. As there are several methods of answering, I wonder if each has the same result -

  1. Using the answer key on the display
  2. Picking up the handset when ringing
  3. Using the speakerphone button while leaving the handset on-hook
  4. Checking the EHS and headset settings.

I have no one else complaining, but then perhaps they are happy about someone else getting the calls.

If you are in a position to submit a ticket, please, feel free.


#20
  1. Using the answer key on the display
  2. Picking up the handset when ringing
  3. Using the speakerphone button while leaving the handset on-hook
  4. Checking the EHS and headset settings.

We tried all of those, same results.

Our traces show that the phone never sends an OK/answer packet back to the PBX. This a client that gets 100-200 calls and it happens on about 10% of them. They are legitimate callers because someone else in the RG is able to answer.