GXP2160 handsfree loop


#1

Hello.
We have several units of the GXP2160.
The thing is, they’ve been working fine until a couple of months ago. Probably after some firmware updates.
The error is that, when the operator is answering a call with the handset and another call comes in, the phone activates the handsfree and both the ringing that sounds in the operator’s speaker and the ambient noise is heard by the caller of the first call which is quite annoying. It is a kind of handsfree loop.
The operator does not touch any keys to make this happen. The configuration remains the same as it was when they were installed and has worked well for almost a year.
When we noticed the error, the phone had version 1.0.11.6 installed. To see if it was fixed, I installed version 1.0.11.10 but it didn’t work. We had 1.0.11.3 installed before, but I can’t tell if we didn’t already have the problem with this version.
Of course, I have checked the call features values and everything seems to be correct…
After upgrading, I also tried to restore one of the phones to factory settings and reconfigure it from scratch, but it didn’t work either. This is the only thing I have seen in the GrandStream forum for a similar case.

If anyone has any suggestions, I’d be happy to try them out.

Thanks in advance.


#2

Log into the handset and navigate to the Settings --> Call Features --> Disable Call Waiting Tone --> checkbox – Yes --> Save.


#3

Thank you very much for your answer, Scottsip.

By adjusting the settings to the values you send, the operator does not hear a tone in the speaker or in the handset when a call comes in. It just appears on the display.
I put an image of the configuration we have configured. This is the configuration that, for months, has worked as we wanted it to.
Before, when a second call came in, a beep sounded in the headset but at the same time the tone sounded through the speaker BUT it did NOT activate the handsfree which is what now makes the person on the other end of the first call hear, in a very annoying way, the ringing tone that sounds through the speaker.
The problem is that the handsfree is activated when the second call comes in. Without touching any keys.
That’s why I think it’s a problem with some of the latest firmware updates. This same configuration, as it stands, worked fine a few months ago.

image


#4

To continue with this topic. We have tried to put a GXP1630 (with the latest firmware version of this model) as an input terminal and with the same values for call waiting as the GXP2160 and NO failure occurs. So my suspicions that the cause is one of the latest firmware updates are becoming more and more accurate.
By the way, it is impossible for me to communicate with Grandstream’s HelpDesk… The login screen gets me nowhere when I enter my credentials.


#5

We are seeing this same issue. Suddenly started occurring - not on all calls but some. GXP2160s and GXP2170s. Some phones are running 1.0.9.127. Others 1.0.11.10. Happens on both. Never saw this before in 15 years with Grandstream devices. We have a customer doing a very high volume of calls and it is freaking them out.

ps: Disabling call waiting tone is not an option.


#6

this is an old post, it is better that you open a new one giving scenario and details,
it’s not necessarily the same problem as the post


#7

Yes, it is an old post… it has TWO MONTHS…
We still have the same problem and we are still waiting for the people in charge of Grandstream to give us some idea about their solution…

We have had advice from a user and I made other tests that I published… But officially there is no answer…

But if it is necessary to upload the post every week, don’t worry, I will make sure it is in the top…


#8

Two months is not old in the world of Grandstream (trust me - been with them since the days of the BT100). Better to combine and compare experiences in a single thread.


#9

Hello.

We have updated the phones to version 1.0.11.16 and reconfigured them from scratch.
The bug continues to appear.

We are still waiting to solve it…

P.S. Now the LDAP queries for phone number recognition have stopped working (in the GXP1630 they still work)… but this is for another post… :wink: