GXP2140 Voice Feedback on DND Feature


#1

Not a huge issue, but i’m getting a lot of negative user feedback on this:

Whenever the user hits the DND button, a voice states either ‘Do not disturb has been activated’ or ‘Do not disturb has been deactivated’

How do I disable this? I couldn’t find the setting in the phone admin to pull the p value for my config file.

Thanks


#2

What firmware? Our 1.0.9.102 phones don’t do that, they just put up a big red do not disturb display.


#3

It depends on where the DND is being applied.

If the DND has a code that is being sent to the UCM or other PBX, the UCM, upon seeing the code, is the one that is responding. At this point the DND is being handled at the UCM level and no calls will be sent to the extension. The phone has no pre-recorded voice prompts. You can look in the web interface of the phone and see if the DND settings have been populated with the codes that are applicable to your PBX or provider.

If the DND is applied at the phone, then the phone is managing and will send a 486 response to every INVITE. The issue might arise that when the DND is at the phone, it may “chirp” like it is starting to ring, but then realized that DND is applied and will stop.


#4

@lpneblett, our understanding on a GXP21XX phone is that the DND button is an endpoint thing and sends no data, just returning a 486. SIP packet captures confirm this. So @dandickson, can you confirm the specifics of firmware, phone model, and what button you’re referring to specifically?


#5

It must be PBX notice for sending code.
So you can only edit this on PBX side or remove sending code to PBX. You can check it here:


#6

We never knew about those features. This is what we get for coming from a Cisco side of things. Grandstream phones are so much more feature rich. Thanks for teaching us something.


#7

Well now I feel silly posting, the voice prompting is coming from the voice switch.

The phones are running 1.0.9.102, is this a change in behavior from previous firmware? I have snom and polycom devices, they all execute dnd at the handset.

Is there a way I can make the grandstream hardware handle dnd at the handset instead of at the switch?

Thanks


#8

Our 2160s and 2140s are running 1.0.9.102 and do not exhibit this behavior. They are all doing DND at the phone level, not sending feature codes to the PBX.


#9

It’s configured to do it at the PBX level just like the screenshot, *77 and *78

Where is the setting to handle it at the phone level?


#10

Delete the text in those fields.


#11

Thanks for the assist


#12

Does anyone know how to delete the text in those fields using the P Codes on the Grandstream?

I’ve got a system that all the phones had their feature codes automatically populate with the *78 and *79 feature codes. When I remove the *78 and *79 text on the phones it behaves exactly how I want. I would just like to know how to do that in bulk using the P Codes.

Thanks!


#13

You should be able to provision using:

#Do Not Disturb (DND) - On
# String
P2344 = 

#Do Not Disturb (DND) - Off
# String
P2345 =

It should erase the field.


#14

Thanks for the quick reply! That worked! Thank you!


#15

Excellent! Marking this thread as closed.


#16