GXP2140 Download Device Configuration problem


#1

Background: I have a couple of phones that work differently and I can’t figure out what is different between them. I got the bright idea of doing a Download Device Configuration on each of them and comparing the two. (If I recall correctly I have to sort them first, as the order is not defined.) Firmware is the latest official firmware, 1.0.9.108.

But if I do a Download Device Configuration I get a very short file with maybe 20 P-values. I thought it was supposed to list all of them. There should be hundreds.

I’m working with Grandstream support on this but have been unable to get the support person to understand. (Ticket #20181114095406).

Am I correct in my understanding of what Download Device Configuration should do? Could someone with a similar phone try it to see if it is a bug in the firmware?

As a workaround I’m trying to modify one of my old Powershell scripts to compare P-values in a pair of devices using SSH. If I get it working I’ll post it.

Yes I know I should be using Zero Config, and that doing so would solve my problem. I’m just afraid to try to convert over, plus I think Zero Config can’t be used on phones connected using OpenVPN and I have a couple of them, one of which is one of the phones I’m having trouble with.

Thanks,

-jimc


#2

Are the config files with 20 Pvalues identical on both the working and nonworking phones?


#3

I haven’t gotten to that point yet. I’m starting with downloading the configuration from my phone before moving on to phones at the customer site.

But Grandstream support actually came through, finally. It turns out there are now two configuration download options: Download Device Configuration and Download User Configuration. I wanted DDC but was picking DUC. I think the DUC is supposed to give just the User Account settings, but it doesn’t look like it’s giving all of them.

I think that DDC used to be where DUC used to be, and DDC is now higher up on the page and easily overlooked.

Thanks,

-jimc


#4

AFAIR I have been able to use Zero Config to provision a remote phone over a VPN (have not tried OpenVPN).

I think the issue with Zero Config will be that before Zero Config is able to work:

  1. You will need to configure the all the subnets correctly in Zero Config, and

  2. More importantly (and limiting) the phone must have connected with the UCM on the local network and configured by Zero Config before Zero Config will work with a remote phone. [This is a limitation I have been told about a couple of times by Grandstream tech support and I have not heard that it has been changed.]


#5

Re: Zero Config… most importantly I’d have to start using it. I’m sure I’d break something if I tried, and I don’t want to do that. If I was starting over I’d use it for sure.

-jimc


#6

I wrote a Powershell script to compare the configuration of two phones and list what’s different. It might come in handy for someone someday.

It needs Powershell 3.0 or higher, and may need that you install the Posh-SSH package. On Windows 10 it will just work. You have to edit the script to include the correct IP addresses and admin passwords. It has a list of ranges for P-values to check because it’s not fast enough to just check all possible ones, which is currently set up for GXP21xx phones. Adjust it for other phones. Results are written to a file in the %temp% directory.

gscmpp.zip (1.7 KB)

-jimc


#7

You can also use Notepad ++ to open two files and do a compare. It will compare every line and show variances. May be a bit of overkill if only want to compare a group of P-values, but works straight from the app without much ado.

You should be able to use ZC across a site-to-site VPN without issue as long as the ZC config settings take into account the remote LAN, the remote LAN segment is in the NAT and hopefully the local and remote LANs can be contained within the same subnet mask. In other words the UCM uses the subnet mask to know what are the allowable ranges it will scan should you use a broadcast IP. I have VPNs where the segments are 10.10.10.X, 10.10.20.X and 10.10.30.X. By using a subnet mask of 255.255.224.0, ZC will allow me to scan or look at any IP within the /19 range. It I scan the range it may take a while, but I can.

So, now then, what did you find that might account for how the phones act differently?


#8

That’s a great idea, using a compare program on the two downloaded configuration files. I will give it a try.

I’ve given up on my SSH compare program. I can’t get the timing right… it almost works but over a VPN things get a bit scrambled. If anyone is interested in it let me know and I’ll give you the latest version. It does work when the phones are local.

Regarding VPNs, yes Zero Config should work on a site-to-site VPN but I’m using the OpenVPN support built into the phone, to connect to a VPN server located on the office network. Given that setup, I don’t think ZC could work. Maybe if the phone was already set up with the VPN parameters it would keep the VPN configured but starting from a factory reset, no way.

And no, I haven’t figured out why the phones work differently. I may end up having to actually do some old-fashioned troubleshooting.

Thanks for your help!

-jimc