GXP2140 delay on incoming audio with USB headset connected



I have a GXP2140 VOIP phone which accumulates a delay on the incoming audio at a rate of 3s/hr whenever I have USB headsets plugged in. I’ve tried the Grandstream headsets and Logictec headsets and have updated the firmware to Thinking any number of network devices in between the two phones could be contributing to the problem, I replaced all that tech with a crossover ethernet cable in order to connect the two phones directly to each other. All I have are the two phones separated by a cable. I initiate an IP call via the 2140, wait a while, and the delay is back and continues to accumulate as before. I’ve tried different phones connected to the 2140 and the problem remains. This problem does not occur however when the headsets are not plugged in, and the handset is used instead.


What you are describing may not be something that forum members can do much about. My take is that a packet capture is needed from both phones while doing a call between the two. However if the call has to last an hour or more in order to experience the delay, then it is unlikely that the phone has that much storage.

The only thing I can suggest is to submit a ticket describing the issue as completely as possible and see if GS can duplicate in their labs.


I would suggest to use dedicated non USB headsets, perhaps the likes of wired Plantronics headset or Jabra’s headset range with RJ9 connectors. There are Wireless headsets that are also in the RJ9 connection series.

I mention the wired solution because I have never experienced what you are enduring using USB with an RJ9 connection.