GXP2130 - Not able to transfer via MPK


#1

I’m trying to transfer an ongoing call to another internal phone with a single touch to an MPK.

I can transfer the call by pressing the physical transfer button (2 phones) and enter the number.

If I program a MPK to “speed dial” to that number, I can transfer call by hitting the physical transfer button and then the speed dial MPK.

I was NOT able to integrate this “transfer function” into the MPK. If I switch the action of the MPK from “speed dial” to “transfer” nothing will happen.

Am I missing something?

Here the config:

Grandstream GXP2130
Fritzbox 7490

Software Version

Boot 1.0.7.2
Core 1.0.9.94
Base 1.0.9.130
Prog 1.0.11.10
Locale 1.0.11.7
Recovery 1.0.9.98

Settings - Call Features:
Disable Transfer: No
Attended Transfer Mode: Dynamic
Transfer Mode via VPK: Attended Transfer

Multi Purpose Keys

MPK 7 Transfer Account 1 Tr XXX IP **620#
MPK 8 Speed Dial Account 1 XXX IP **620#


#2

**620# ??? normally you need put only number there as phone sent transfer in packet (no need codes).
Also Attended is 2 stage so it will not be transfer, you will call other party then you must transfer. Blind trasfer is sending call.


#3

Sorry, I forgot to mention that these two phones are “internal”, i.e. they are both connected to the Fritzbox. That’s the reason for the: **620#

And I want to transfer an ongoing call to the other “internal” phone with one touch of a button. That phone has the “Fritzbox number” **620#.

At the moment I press (transfer) then the MPK (configured with: speed dial **620#).
The other phone answers, I hang up.

My goal is to have that on a single MPK (i.e. Transfer **620#) which does work on older Grandstream phone in the office, btw, but not here.


#4

Dial plan restriction ?
# as dial ?

Check this


#5

Yes - I used “#” as “dial immediately”.

After removing it, the “transfer” option does work as expected.

Thank you - Grand Guru :slight_smile:


#6

Set the Keys to BLF.
Also enable Enable transfer via non-Transfer MPK
at the phone.
You can find this setting here:
Virtual Multi-Purpose Keys Settings