GXP2130 DHCP Vlan


#1

Hi all,

I´ve been trying to configure IP Phone VLAN on a GXP2130 via DHCP. I configured option 132 in my dhcp server, but it doesn´t seem to work. This document says it is only possible in GXV32xx phones (https://www.grandstream.com/sites/default/files/Resources/VLAN_Guide.pdf), but in my GXP2130´s web GUI appears the “Enable DHCP VLAN” option. Do you know if it really works in other IP Phones, not only GXV32XX?

Thank you very much


#2

I don’t know if this feature is limited to the GXV32xx but the P value is 8300 which isn’t documented in the 21xx template files.
However if I look at the webgui source on my 2135 (I don’t have a 2130 to hand) I can see this
image

Doesn’t mean its been implemented in the firmware though. My handset is at 1.0.9.102.
If you want to check whats happening run a trace to check the behaviour as shown in the vlan guide


#3

I looked at both the manual and the firmware release notes:

  1. The manual indicates the VLAN option must be set manually for the GXP21XX.
  2. The latest firmware BETA release notes for 1.0.9.108 indicates -

My suggestion is to set it up manually and see if it works first so that you have a base line by which to know the expected functionality. Once done and working, then update the phone to the Beta and then undo the manual settings and then try the DHCP options and see.

It could be that the manual will not be updated until such time as the BETA is out for general release.


#4

I have a similar problem. When we factory reset a phone, it will not automatically switch back to the correct vlan even though dhcpd.conf option 132 is set. The Grandstream DHCP_Options_Guide PDF file (page 17) has some packet captures showing the phone should do a request for option 132 - but GXP2160 does not do this.

I added to my dhcpd.conf:

option vlan-id code 132 = text;
option vlan-id "34";

I did similar captures on my GXP21XX phones and these phones do not request option 132 so even though the server has option 132 configured so it does not send it.

I’ve also tried forcing a send with

option dhcp-parameter-request-list = concat(option dhcp-parameter-request-list,84);

This forces dhcpd server to send the vlan-id, wireshark shows it is sent, but the phone does nothing with option 132.

Here is the wireshark capture for the DHCP Discover coming from the GXP2160 - note NO request for option 132:
GXP2160_dhcprequest

Please add this feature to the GXP21XX phones so they auto-provision onto the correct vlan after a factory reset. Thanks.


#5

Actually, the guide states -

So it appears that the guide accurately indicates the current operation, but like you, I wonder why there is not a consistent method between all models?


#6

Yes. Is this forum where we submit the feature-request bugfix?


#7

No, for bug and features best is use GS ticket system:
Especially BUGS.


#8

Ok thanks. I’ve created a bug/feature request in the GS ticket system with reference back here. Let’s see how it get’s processed : )


#9

Some good news on the ticket with Grandstream support regarding adding dhcp vlan configuration after factory reset:

Abderrahim @February 11, 2019 08:21
I will add your request to our database for consideration!

Thank you again for contacting Grandstream technical support,