GXP2110 Automatic Provisioning Reboot Loop

end-of-life

#1

I’ve trying to configure a GXP2110 using the old style binary configuration tools cfg. It is able to pickup the configuration settings but if I leave the configuration url in place it will continually reboot. I put it onto syslog and the phones keeps printing the following message.

Nov 24 18:38:09 192.168.10.167 GXP2110:[00:0b:82] HTTP read file http://192.168.10.31/cfg000b82XXXXXX succeeded
Nov 24 18:38:10 192.168.10.167 GXP2110:[00:0b:82] Load config setting
Nov 24 18:38:11 192.168.10.167 GXP2110:[00:0b:82] System reboot is requested due to config setting changed
Nov 24 18:38:13 192.168.10.167 GXP2110:[00:0b:82] System reboot is requested due to config setting changed
Nov 24 18:38:14 192.168.10.167 GXP2110:[00:0b:82] Provision setting is Always Check for New Firmware at Boot up

Does the GXP2110 really support the old configuration file format or must I switch to XML provisioning?


#2

I had the same problem. It looks like a bug in the Grandstream template file. gxp21xx_config_1.0.1.26.txt
The problem occurred on both 2100 and 2110. I was able to use the old config method by just putting only the minimum parameters into a config file template.

Bug explaination: (Grandstream please take note)
With all previous template files they contained the default parameter settings. The sanity test for debugging was to just use the template itself to generate the cfg file and it would reset the phone back to the default settings. This does not work with the 2100 and 2110. It puts the phone into this endless reboot loop. My assumption is that there is some form of an offending parameter in the template file that the new firmware can not deal with. A fix or work around for this would be greatly appreciated.


#3

It really has to be fixed. I managed to force the phone to stop boot looping by changing (during the looping) the configuration file with a file having an empty “Config Server Path” field.


#4

I can’t really roll these phones out on our system until this gets fixed. I’ve tried only setting the parameters that change and still encounter the loop when i populate the configuration URL.


#5

Pull the ethernet plug when the accounts start connecting… Wait 10 seconds plug it back in… At least it works until you reboot again…


#6

I found it stopped rebooting after I commented out the SSL-parameters P280, P279 and P281.


#7

hello,

i’ve got the same problem here.
this way the phone is usable for homeusers, but not in enterprise production area.


#8

I have the same problem with 80 phones in STUCK.
There is no documentations around Internet to fix the bug.

Some one can help me to identify the value of the follow parameters= P280, P279 and P281

Thank you in advance, next time I chose different brand.


#9

I’m hitting this same issue.

Only renaming/moving/making unavailable the cfg* file does the looping stop.

:confused:


#10

My findings:

  • Only happens with the beta version of the firmware (1.0.1.39)
  • Happens no matter what you have in the cfg file, I shortened mine down to less then 10 entries, just enough to connect up, and it still rebooted.

I downgraded the firmware to 1.0.1.26, which stopped the rebooting.


#11

I’ve been at 1.0.1.26 the whole time and I still get the reboot loop.

  • n

#12

Mine is acting differently today then when I last test it. The short config works, but my normal long config doesn’t. It works fine on the .26, but when I try it on the .39 firmware it will boot up, then say “Downloading Ring Tones”, and reboot. Is that when your reboots as well?


#13

Ok, new information for everyone. I have found that if I set P64 to EST5EDT then the phone will go into a reboot loop on the .39 firmware. However if I comment that line out or set it to CST6CDT it works fine. If you are having the reboot loop problem with the beta firmware, try commenting out P64 and let me know if that works for you as well.


#14

I’m still running into this problem with the latest firmware 1.0.1.66. I’ve tried not setting option P64 and P264 to no avail. Was anyone else able to resolve this problem? Has grandstream even acknowledged an issue? Basically I’m recommending to all our customers not to purchase any phones in the 21XX line.


#15

7 years ahead and the problem remains.

Our P64 was set to COT5

Setting P64 to auto solved our infinite reboot problem on our GXP1610

Please be aware of this Grandstream.


#16