GXP2010 phone and ucm6202 blf failure


#1

Hello
I have a GXP2010 phone and ucm6202
I have problem with blf.
After phone reboot evrything works well, but after some minutes blf are not working.
I have a cisco spa phone and blf works just fine, so the problem is with GXP2010 setup.

In GXP2010 account1 menu i have:
Register Expiration: = 1800
SIP Registration Failure Retry Wait Time: = 20
Session Expiration: = 180
Min-SE: = 90

I can give you more details if you need.
Thanks John


#2

The settings you posted are not really related to the issue, but to registration periods and timers while in a call.

BLF indications are done through a subscribe and notify process. The phone will subscribe to the PBX about the other extensions it wishes to monitor. Once subscribed, the PBX will then send a NOTIFY to the phone letting it know of a change on the monitored extensions.

You would need to do a Ethernet capture to see if the messaging is being sent correctly, In the meantime, you might try -

  1. Factory reset the phone and reprovision.
  2. Move the phone to a different location; perhaps exchange places with the Cisco for a bit.

I take it that the phone remains registered throughout and that there is no issue when making or taking calls? If so, then I would start with the factory reset.


#3

Thanks lpneblett

I’ve done the 2 steps you mention, but the problem is still there.
The only solution i found is to increase the Register Expiration: to 720 minutes.
And now i have to wait 720 minutes and see what happens.

After some tests i’ve done, when i put Register Expiration: to 1 minute, after 1 minute the GXP2010 blf stop working.
I did the same for 2, 3, 4 minute and find that blf stop working after the period of 2, 3, or 4 minutes.
Everything else in GXP working fine, only the blf is a problem.

Before the ucm6202 the GXP2010 was attached to elastix, and everything was fine.
Till GXP2010 attached to ucm6202 started the problem.
So mabe the solution is in ucm6202 setup or firmware, and not in GXP.

Thanks John


#4

Change the period to 2 minutes in the UCM and then start a network capture, Reboot the phone. when the phone is back and running make a call from a monitored phone to voice mail and see if the BLF changes. Do this every 30 seconds for a few minutes or until the BLF fails, Then stop the capture and post or PM me with it. \

Depending on how busy the network is, the capture has a limited capacity, so hopefully you can get the issue to surface within a few minutes.


#5

Hello lpneblett

Thanks for the instructions, but what to change in ucm?
From /pbx settings/sip settings/misc/register timeout ? or something else?


#6

Register expiration.


#7

Hello!

I think I found a solution!
I’ve made some changes in the configuration and now blf is working fine.

The changes are:
In GXP2010
/account1/register expiration = 3600 (default =60)

In UCM6202
/Extentions/Concurent registrations (for the current extention) = 10 (default =1)
/Pbx settings/Sip settings/Min registration subscription time = 60 (default =90)

All other setting are the default.


#8

The settings you describe being made in the UCM are:

  1. Concurrent registrations - a security measure to limit or set the number of extensions that can be registered to the PBX at any given time using this extension’s attributes - extension number, authID and password.
  2. Registration period (min) - is the minimum period of time that the UCM will allow for a registration and subscription.

#1 should have had no impact with regard to the BLF.
#2 should have had no impact with regard to the BLF either. This is a time setting within the UCM that tells the UCM that when a extension registers, as long as the requested registration is between the max and min times, the registration will be allowed. If it falls outside of the limits, then the UCM will send the extension an expiry period which is the default. When you set the phone to 3600 and the min in the UCM to 60, you matched and the UCM will accept the register request as is.

The phone had previously been set to 1 minute, but the UCM should have changed the expiry to 90 (at the time which was the default).

However, while the settings are only time related and should not have had any impact on BLF functionality, if the changes have seemingly fixed the issue…then no arguing with success.