GXP1760W Bricked with green envelope showing?


Phone has been fine for 2 years,noticed today wasn’t ringing and unresponsive.

Rebooted, now only shows a green enevelope in top right, LCD and buttons are dead.

Is there any warrany on this, or is it now landfill?


Have you tried updating the FW?
Have you tried doing a format factory?
you must contact your supplier to understand if it is under warranty or not,


Hi, thanks for replying.

The LCD screen is not powered, and the buttons are not respsonsive. It’s my understanding that with the LCD and buttons not working there is no way to update the firmware or perform a facrtory reset, as they require the screen to work?

There is literallty just the green envelope lit in the top right of the phone (not on the LCD screen, a separate lamp) when power is applied - otherwise the phone appears dead - even though LCD was working this morning before I unplugged it.

Is it toast? Is there any kind of factory reset I can do without the LCD coming to life first?


the format factory you can do it from LCD,
you can do it from WEB GUI,
you can do it from SSH

you can find all the instructions in the online manuals,
in any case below you have the references of Grandstream Support


There isn’t any boot process - it doesn’t get that far, just a green envelope, but no LCD.

I note this from this post over 2 years ago https://forums.grandstream.com/t/grandstream-gxp-1760w-led-screen-went-dark-only-green-light/40810 that appears to be a known problem, and one of the posters had 17 (!!!) phones die with the same problem,

Time for the bin it seems.