GXP1625 is not gathering correct Timezone hour, even with DHCP Option 2 Override enabled


#1

Hi,

I have several GXP1625 IP telephones installed here. So I updated firmware to 1.0.4.132 and enabled Time and Date to these settings:
gxp1625
At my DHCP server I enabled these values:
dhcp

But they are not working! (My Time Offset is -4UTC) so my device might have GMT -4 hour. Instead of it, it’s showing UTC Time.

Any ideas to solve it? I’d rather to work by this way, because we have a great number of these devices, and changing timezone manually one-by-one is hard. Here in Brazil the government change Daylight rules almost every year.


#2

check that you have not set any forcing on Zero Config


#3

I’m searching for this feature within GXP1625, but no luck. Is this a server feature for IP clients?


#4

let’s start all over again, where are the phones registered?


#5

They are registered in an Asterisk server, but I didn’t found any settings related to it on the server,unless to it:
sip

But I saw that 172.24.0.200, told as NTP Server, is not running at all, as I tested here:

$ sudo ntpdate 172.24.0.200
18 Feb 14:51:30 ntpdate[25328]: no server suitable for synchronization found

I decided to change NTP server to a valid server (172.24.3.1) and changed Time Zone to America/Cuiaba. After that, rebooted device and now it’s GMT-3, or, 1-hour ahead.

Better saying, I keep having problems to set correct time. Any ideas?