GXP1610 RTCP & Problem with connection failure after 10-15 seconds


#1

Help me figure out rtcp. In phones (base) DP750/720 in the web interface, it is possible to enable the rtcp Protocol, and they have a problem with connection breaks resolved. However, GXP1610 does not have this setting, but the specification supports this Protocol. What should I do?


#2

RTCP is just an RTP flow verification protocol, on the phone I don’t think you can set anything for this,
exactly what problems do you have?
scenario? details?


#3


I know what the Protocol means. In DP750, enabling this Protocol helps solve this problem, but GPX1610 does not have this setting. So I ask, what can be done? The provider points to this Protocol, but I can’t find this setting.


#4

Hi,
It seems there isn´t even a P-Code for it.
For DP75X it´s this P-Code:
#Enable RTCP. configure if enables RTCP statistics and control information. 0 - Disabled, 1- RTCP, 2 - RTCP-XR
#Number: 0,1,2
#Mandatory
P2392=1

But I didn´t find anything in the gxp16xx_config file.
So I would recommend to open a ticket for that.


#5

the GXP16XX series is basic and has no modifiable RTCP options,
you can open a ticket as it tells @grandgrand you and ask for a feature.

It’s the first time I’ve heard “The provider points to this Protocol, but I can’t find this setting”


#6

@damiano70:
Have a look at the datasheet:
Protocols/Standards
SIP RFC3261, TCP/IP/UDP, RTP/RTCP…etc,etc.
So I think dwgrell has a good chance,that it will be implemented.
I never needed this option as well but it will have some sense, otherwise this option would not exist in general :thinking:


#7

Thanks. Why actually declare support, but not be able to use it. The scale of our small and medium-sized businesses, and there is no desire to change the fleet of phones-the management will not understand. And the provider is such that it will not bend for us, alas.


#8

Unfortunately, changing our provider is not an option.


#9

Why aren´t you able to use support?
Just fill out a ticket and someone will help you…


#10

Yes, thank you, I created a ticket. I hope for a successful outcome.


#11

I do not use the 1610 model, but have you done a capture of a call to see if it is not enabled already?


#12

So it should not be enough for me that the call ends synchronously on the caller and the called phone?


#13

That would have nothing to do with RTCP and call ending. Calls are set-up and broken down by SIP. RTCP is a monitoring tool that can be used by some providers (most do not) to determine the call quality and then suggest a different codec (which is then a SIP re-invite).

A capture is a diagnostic tool that allows you to see the messaging between the devices to determine if RTCP is there as well as the SIP messaging to see how or why the call had issues.

You asked about the setting to enable/disable RTCP. I only suggested using the tool to see if RTCP was not already enabled. Many device use RTCP by default and there is no setting to enable or disable. It is enabled 100% of the time.

I do not begin to understand how you tied my suggestion of using a diagnostic tool to that of not having calls work correctly. I assume a translation issue.


#14

I also attached a picture where I made it clear that the connection is obvious. I personally checked that disabling RTCP in DP750 leads to a break at the 10th-15th second. It is obvious to me that I need to enable RTCP in GXP1610 to fix this problem.


#15

I saw the picture. And as mentioned, just because the GUI does not show the option, does not mean that it is not there. And, you never mentioned that you disabled the option in the DP750 and the call dropped until this last post. Mine was a suggestion, to confirm it by seeing the actual messaging, nothing more and nothing less… and not knowing about disabling it in the 750 at the time.

As you have submitted a ticket, hopefully support can help.

Good Luck.


#16

99.99% RTCP is managed by default, there are simply no options to disable or modify it.
In my opinion, the VoIP manager told you “unreliable” information or wanted to understand something else.