GXP 2170 using alert header field to specify different ring tone?


#1

Hello everyone. We have gxp2170 phones and use the ucm62xx PBX. Right now we use a calling queue to bring in outside calls and it would be really helpful to have a different ring tone than calls from internal phones. It looks like the call queues can put alert information about a ring tone in the header of a SIP INVITE

So if I can put this info in the invite, I am wondering how I can program the gxp2170 to then use this to select a different ring tone.

It looks like I can match a caller ID here

Any help is apperciated.

Steve


#2

Steven

You can assign a different Ring Tone from the Inbound Route Page.

You can Also assign the Queue a Name and it will show on the 2170’s screen on an inbound call as well.


#3

Thank you for pointing this out. I changed the alert info on the inbound route and my gxp2170 rang with the default ring tone.

I think that I need to change something in the gxp2170 so that it knows to act on the alert info header information. Also don’t I need to upload the different ring tones to the phone or are there standard ones?


#4

There are standards. These will be the ones labeled as DR.


#5

Thanks. So this is the standard one

But my phone’s ring tone is still at the default. :frowning:


#6

TRY TO DO THE MATCH on the phone as it was suggested above, then if it works you manage it with zero config


#7

Where do I set this in the phone settings? I can only find this


#8

I don’t see where I would select Bellcore-dr2


#9

the match at the bottom of the screen


#10

The DR ones are standard and will not be available in the phone as a custom. If sent in the alert header it will automatically ring the associated DR tone. Try a different one and describe the route.


#11

So I should put in Bellcore-dr2? or is there a different pattern/special pattern?

image


#12

And if this is the case, then how would I pick the Bellcore-dr2 ringtone as it isn’t listed under the ringtone selections
image

Would it be the system Ringtone?


#13

must fill the “matching rule” field, I wrote it above


#14

No, there is no need to input anything if using DR.

By chance, do you have this setting enabled (yes)?-
Ignore Alert-Info header This option is used to configure default ringtone. If set to “Yes”, configured default ringtone will be played. The default setting is “No”.


#15

Here is what I tried
image
Here is the inbound route

I saved and applied and still getting the default ring tone.

@lpneblett - Is this setting in the PBX? I checked the phone and ran through all the fields but could not find the word ignore. Could you point me to the right section?

Thank you very much


#16

Found it!!!
image


#17

It sounds like I might need to look at the sip header to see if the alert-info is getting in there…


#18

Remove the matching rule in the phone. That is not needed and if you look, it is to match a caller id and bellcore is not a caller id.


#19

image

Still no love :frowning:


#20

It does say that the pattern for the ring in the alert pattern can be put in here, but I tried it both ways and it didn’t work
image