Does not appear to be a category for the new GWN78803 switch line! DId I just miss it?
Just received two in the mail to test and thought I’d start a thread to discuss.
John P.


Nothing has been started yet. I got one of the 7802p, haven’t done much with it yet except connect to Hopefully will move all equipment this week to it and see how it performs.


Hey Zach,

Let me know how your testing goes. So far, they seem stable and I’m impressed with the configuration.

I placed both in our lab environment, pulling out a pair of Cisco CBS250-24P switches.


So far it’s working great. I also like that the overall size, at the least the 16 port, does not go to deep into the rack. I kind of wish the port lights would stay green if the device you plug in is 1g and POE. It goes to amber. Interface is nice, very simple to use IMO. @whowe82 has posted a short video if anyone is interested.


@bvanmeter The blue save button in the switches – can we get that to blink or prompt us the way that a UCM does – right now it just stays blue. Maybe if there are no changes it dims to a different color?


Probably will be fixed, it is minor bug :slight_smile:
They look good, lets wait for more test and prices


Grandstream does seem to stay on top of bug fixes!
So far, I’m impressed with the first release of these switches.
Looks like the 48 port version will be out March of this upcoming year.


Got one of each model last week. I’ve had the 7802 and 7803 in a test setup. They seem to work well so far. I actually installed the 7803 in a live network over the weekend. The customer is next door, so I can just walk over and correct any issues. A few things I have noted and would like to see addressed in future FW releases.

As stated above do something with the blue Save button, maybe have it go away unless changes have been made (like the UCM’s).

Add the capability to sort fields by headers. Example, on the MAC addres table, it would be nice to sort the list by port or by MAC.

I really like the fact that out of the box all the ports are in Trunk mode with a PVID for VLAN 1

Boot times are decent. My observations are.
Ports start providing POE at 1:05 , VLAN 1 IP address answers a ping at 1:30, Login Screen is available at 2:03. No noticeable difference in a warm boot from the GUI or a hard boot.

With the recent update to I was hoping for configuration from You can add the swtich to a network, manually from the cloud page, or use the mobile app and just scan the barcode. Ofcourse you will need the factory pw to login. The only “configuration” option in the cloud it remote connect like it is to a UCM630x. Maybe actual configuration will come later.

I had issues finding where to change the admin password, and found it by clicking on the user icon in the top right of the web page. Reboot is there also.

One last thing and it is a big one for me. The switch is really QUIET… The one I place in service next door was replacing a TP-Link TL-SG2428P. I did not consider the TP-Link to be that loud, not when compaired to an older Cisco switch. But when I migrated the phones and AP’s over to the GWN7803P and unplugged the TP-Link the telco closet went quiet. Major difference. I do not have any decible readings to reference but the difference was very noticable. I did hear the fans speed up a couple of times, but still not loud at all.

Just my two cents worth. Will post more later as I learn more. Looking forward to the 48 port models.



If you want to set a static IP on these switches, the option is under System, login services. You should see VLAN1 and you can adjust from DHCP to Static IP and set what you want it to be. This seems like a weird location for this but that’s my opinion, I am just glad I finally found it.

After setting static, DNS is not working and it shows offline in GWN. I have not found a location on the switch to adjust DNS. Switched back to dhcp and it shows back up in GWN. So I have set a static mapping on my router so it uses the IP I want and it is showing in GWN. No idea why DNS is not working when you set a static, I will contact support and see if they know. Has anyone else set a static on your switch and it still shows up in GWN? @whowe82 have you tried this yet?

@daver56 I have a similar tplink 24 port and I thought it was quiet too, nope! These new switches are super quiet.


I have a ticket open with Grandstream on the switch/ issue. They replied that they are aware of the issue and working on a resolution and they will keep me posted. I will update this if I hear something.


HI Dave, thanks. I also have a ticket opened, hopefully new firmware soon.


Showing offline in when using a static ip has been fixed in firmware