GWN7610 Captive Portal Facebook authentication


#1

Hi,
I have setup my guest network to facebook authentication. But I always get warnings about unsafe site, because browser does not trust the certificat. Is there a way to get HTTPS to work, without getting error messages?


#2

No, broswer always don’t trust selfsigned certificate. Only way for now probably use htttp. Just by uncheck the “Enable HTTPS” in CP policy.


#3

Uncheck the “Enable HTTPS” in CP policy, unfortunately don’t solve the problem.

Since October 6, 2018, all apps on “developers Facebook” is required to use HTTPS .
So “OAuth Redirect URIs” can only be HTTPS.

I will hope Grandstream will solve this issue soon :slight_smile:


#4

Hi, Tonnesen,

Does unchecking that option still not work for you?
You can still use https://cwp.gwn.cloud:8443/GsUserAuth.cgi?GsUserAuthMethod=3 for your OAuth Redirect URIs. When you uncheck it from GWN CP policy, just the first prompt welcome page which was giving you certification warning allows HTTP.


#5

Hi GS_TIAN,

I have tried disable HTTPS in CP policy.
On Android system I have tried with Chrome, Firefox and Opera browser
For Chrome browser it’s not possible to connect Guest network at all - if I accept “unsafe site” I will be redirected to the login page again and again.
With Opera and Firefox, I can connect - if I accept the “unsafe” site after login.

On OS I can connect - if I accept the unsafe site after login.

On Windows only tried Chrome and it’s not possible to connect at all.


#6

Em, interesting, so you still get HTTPS certification even you disable HTTPS. This is different from my test. Which firmware are you using?


#7

Both AP are running FW 1.0.8.7