GWN7600 Refuses to Update to Newer Firmware


#1

I bought 4 brand new gwn7600 from Telephony Depot. They came with 1.0.1.36 firmware. Neither Grandstream techs nor I have not been able to get the units to upgrade from 1.0.1.36 to a higher/newer firmware. We have both tried using local machine and server tftp & http as well as grandstream remote servers for the update but it still does not work. It always report “Upgrade Failed”. When we use the CLI is says firmware not found but we verify and the firmware is exactly where it should be. We also have gwn7610 and have no issues with updating the firmware using the same servers (tftp & http).

Has anyone else had this problem? Any suggestion is appreciated. Thanks.


#2

I have the same problem with 7610s. I have a number of these deployed and this is a first for me. It’s very frustrating.


#3

Try the following.
Turn off option 42 & 66 on the AP. If you are unable to do that then use a DNS that does not provide options 42 & 66. Then point configuration to a TFTP or HTTP server to update the unit. Hope it helps.


#4

I have several APs on different sites that say “upgrade failed” too. I don’t know how to correct this.


#5

Hi, areyouonline.net,

Did you get the upgrade issue resolved? I want to look into the issue if your device still refuse to upgrade.


#6

Same Problem here.
Just installed 8 GWN7600 at a Client Side, and trying for 2 Hours to upgrade without any Chance. AP’s are also on 1.0.1.36
I tried to log on through SSH, but the cli is basically useless as there is only one Menu Option “1” for Status. All other Menu Options are not visible and can’t be selected.


#7

Finally got it working.
Had to use TFTP to update the AP’s.
I first updated to 1.0.3.25, then to 1.0.6.x
Maybe it would work to update straight to 1.0.6.x, but haven’t tested it.
For TFTP I used the freely available tftp Server from jounin. Don’t forget to temporary disable your Windows Firewall. There you can also see if there is a connection from the AP to the TFTP Server.


#8

Good to hear you solved it, lemonmagic.
Thanks all, for your input. I would like to continue to follow up with anyone who hasn’t been able to solve your upgrade problem. Please contact me, either reply in this thread or meassge me.


#9

I have a GWN7000 that worked very well
I installed firmware 1.0.4.23 and after
the name of the wifi disappeared on the smart phone
I also install the firmware of antennas 1.0.8.18
and I can not go back
not possible to install
the BETA version or an old version “Upgrade failed”
who has a solution?
Thank you
the GWN7610 are no longer visible by smartphones
Help


#10

Factory unit then setup again.
It can be infinite amount settings that prevent this. After factory you should be able see default network on unit.
If you see this then AP works ok.


#11

I configured the GWN7610 on the GWN7000 (simple configuration)
Pairing = ok
Add network group = group0 = ok
ssid = GWN2 = ok
password = ok
Members devices = ok (all GWN 7610)
and on my smart phone = no ssid GWN2
Why?


#12

Dual network ?
GWn can prioritize 2.4GHz


#13

Yes I change in the frequency configuration
I thought about that ! but nothing
is there something i forgot to do?
there is an inconvenience with firmware GWN 7610 and GWN 7000?
before changing firmware, it worked
I do not understand

Thank you for your reply


#14

Oh sorry.
You cannot use GWN700 1.0.4.23 and AP with 1.0.8.18 all must have 1.0.4.xx firmware.
Downgrade AP firmware. Or make GWN AP as master instead of router.


#15

Ok thank you I will change the firmware of GWN 7610
if not I must use the master with an antenna
and configure the SSID in the master
If I understood correctly ?


#16

Perfectly :slight_smile:


#17

Marcin thank you
has worked
GWN7000 = 1.0.4.23
GNW7610 = 1.0.4.23