GWN7000: Sample OpenVPN Client Configurations


#1

I recently purchased the GWN7000 and setup the OpenVPN server functionality for use with remote users. The remote users are utilizing Windows 10 and the standard OpenVPN client software. However, I have yet to get a successful OpenVPN client configuration file established. Does anyone have any sample OpenVPN client configuration files that would be willing to share?


#2

AFAIK, the .ovpn file is generated by the OpenVPN server. It generally includes the TLS certificates and private key.

You can try searching Google for one. I also tried configuring oVPN with my 1and1 Cloud Server but didn’t get the routes to work, so I look forward for someone who has a working VPN configuration!


#3

Hi, all,

I just made a widnows and a linux OpenVPN client temaple for connecting GWN7000 server. It can’t include certificates, so you still need to generate them from GWN7000 and download to your client.
http://www.grandstream.com/sites/default/files/Resources/gwn7000_openvpn_client_template_package.zip
Please let me know if it solves your problem, or any log avalible from client/server if it still fails.


#4

Hi,
I am still having issues to connect my Open VPN laptop to GWN7000
The template was very useful to troubleshoot but still having issues, below are the logs from my Tunnelblink
I am having a Mac and my router is issuing the new 1.0.6.28 firmware)

2018-11-17 21:38:13 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

2018-11-17 21:38:13 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2018-11-17 21:38:13 MANAGEMENT: >STATE:1542508693,RESOLVE,

2018-11-17 21:38:13 TCP/UDP: Preserving recently used remote address: [AF_INET]a.b.c.d:1194

2018-11-17 21:38:13 Socket Buffers: R=[131072->131072] S=[131072->131072]

2018-11-17 21:38:13 Attempting to establish TCP connection with [AF_INET]a.b.c.d:1194 [nonblock]

2018-11-17 21:38:13 MANAGEMENT: >STATE:1542508693,TCP_CONNECT,

2018-11-17 21:38:13 MANAGEMENT: CMD ‘hold release’

2018-11-17 21:38:14 TCP: connect to [AF_INET]a.b.c.d:1194 failed: Connection refused

2018-11-17 21:38:14 SIGUSR1[connection failed(soft),init_instance] received, process restarting

2018-11-17 21:38:14 MANAGEMENT: >STATE:1542508694,RECONNECTING,init_instance,

2018-11-17 21:38:14 MANAGEMENT: CMD ‘hold release’

This is repeated time to time.
To configure the OpenVPN server and create the certificates I used the GWN7000 User Guide for 1.0.6.28
And for the client conf, I use your Linux template with the proper IP (ddns) change and adding the ca, the client certificate and the client key path to the ones I downloaded from GWN7000

I am using the latest stable release of Tunnelblick 3.7.7 (build 5150)
Please, let me know if more information is needed to troubleshoot.

Looking forward to your reply
Thanks