GWN7000 multi-WAN failover option not available in firmware 1.0.6.32


#1

I have two ISP connections on fiber. Both are 150mbps.

However when WAN1 fails, I lose internet connectivity.

The Load_Balancing_Failover_Guide says to configure global settings to LoadBalance+Failover, however my GWN7000 does not have this option at all. It only has loadbalance, WAN1 and WAN2!

I have checked in the WAN. Local Routing and the LAN settings, and there is no option for LoadBalancing+Failover.

As it stands today, if my primary LAN fails I lose internet connectivity in spite of having a secondary line.

I am running firmware version 1.0.6.32. I raised a ticket about this 4 days ago, and no response whatsoever from support.

Another general observation - the manuals refer to options that no longer exist, or are different now: For example there is no such thing as Network Group in the latest firmware, but sure enough all the manuals refer to it!

I’ve attached the screenshots of the relevant configuration pages. Any suggestions?

WAN1Config|689x459


#2

For this, I am afraid you will need to submit a ticket to support:


#3

For 1.0.6.x. Failover and load balancing can be accomplished by new feature as “Policy routing”. You can recreate Policy member as set of “interface+metric+weight”. Then you can add your members to a policy.
In one applied policy, same metric interface will perform load balancing by weight, and lower metric will get higher priority.


#4

Is this documented in the resource folder?


#5

Yes. User manual http://www.grandstream.com/sites/default/files/Resources/gwn7000_usermanual.pdf
Starting page 48.


#6

This achieves load balancing but DOES NOT achieve fail-over.

These settings by default ONLY create a load balance policy, and are already configured on my router. However, when my primary WAN fails, I lose internet connectivity. There is no fail-over that executes using this routing method.

I raised a ticket 5 days ago, and no response from support.

Also the load-balancing guide that is published is completely different from the interface for the firmware version interface.


#7

I have the same experience…


#8

Now it has been 6 days since I logged a ticket. Ticket number is 20190610153949. Shows in progress but no updates from support. This is quite pathetic. I see on Amazon that others face the same issue.


#9

so…I went back and rechecked everything, and think I have solved it based on comments provided earlier.

@GS_Tian , unfortunately while you were directionally correct in what you said, your explanation was unclear at first glance.

Here is what happens:

By default, the GWN7000 on version 1.0.6.32 creates the following routing policy members (Routing>Policy Routing) under local routing policies for each WAN link: wan1 Auto, wan2 Auto. These don’t have any metrics or weights assigned to them, and therefore I am not clear what they do. I’d assigned these default routing members to a policy called loadbalance and it wasn’t working.

After reviewing the documentation again today I decided to can the default members that were created. These cannot be deleted, but in my configuration I have decided to just ignore them as follows:

  1. So I created two now members under Routing>PolicyRouting, both with a metric of 1 and a weight of 1, one for each of my WAN connections.

  2. I then created a new policy and added these two members to the policy under Routing > Policy.

  3. I then assigned this policy to Router > WAN > Global Settings and LAN > LAN.

I’ve tested this now and it works fine. A continuous PING to google does not drop even when I disconnect either WAN link (simplest method is to physically unplug the cable).

Another note: I’ve seen some complaints about throughput performance. I noticed that the default MTU for each WAN connection is set at 1500. I have two PPPoE connections, so I decided to test the throughput using ping www.google.com -f -l xxxx (xxxx being packet size). I found that the packet size I needed for my connections to avoid fragmentation was significantly lower than 1500, and different for my two connections. You might want to check this as well and see if you get better performance.

@hleon let me know if this helps you.

An interesting aside, when you use putty to ssh into the GWN box, and go to the section for ports (option 11), then select multi-wan (option 3), it shows three options (Load-Balance+Failover, Failover, Disabled). These don’t show up in the GUI at all! See attached screenshots.


#10

Hi, arvindsood,

Sorry for the late reply causing confusion. Both WANs set to metric 1 and weight 1 is supposedly to do 50:50 load balance. Since load balancing does not split single stream (it assigns streams to each WAN by percentage chance according to the weight), I would guess your ping was directly assigned to WAN2 before you disconnect WAN1. This is probably why there is no interruption. Failover usually takes time to happen, sometimes it could take over 10 mins for WANs to realize. So it is expected to have interruptions before failover WAN kicks in.

And many thanks for the MTU comment. This is very helpful.


#11

Just wondering if anyone was aware of utility that could be run to help optimize the MTU size?


#12

@drostoker there is no automated utility I am aware of. Using ping and changing the packet size is a little tedious but in all took me a few minutes to get to the right value.


#13

@GS_Tian thanks. My point was I had to recreate the policies from scratch to make it work not use the default policies that the system created. Once I did that failover started working.


#14

Thanks @arvindsood.

Can you advise if you ran this while being directly connected to the cable modem or just connected on the LAN?


#15

@drostoker Connected to the LAN.

my GWN is in a different room altogether. So - after ensuring that my load balancer situation was sorted out, I first disabled WAN2 and ran the ping diagnostic to check optimum MTU for WAN1, and then disabled WAN1 and ran it again to check for WAN2.

I know this worked just fine because I also ran a traceroute to confirm that different paths are being used, and my 2 WAN links have different MTU’s.

Hope that helps.


#16

Thanks for the info.

After doing some research I found out something interesting - it seems my Draytek Firwall has a built-in MTU test function to do this. I haven’t had time to try it, but it seems like something that all similar devices should have.