Gvx3350 / IPCOMMS / Frontier HELP!


#1

Greetings,

I have an account through ipcomms and I can input my SIP user info into a software sip dialer and dial all day long no problem0000, but when I plug it into my GVX phone I just get a busy signal when I dial. I have IPCOMMS on chat with me trying to work it through for several hours yesterday to no avail.

I have read that Frontier can be dicey with voip other than their own solution, but if that were the problem then I wouldnt think the softdialer would work either.

I have udp 5060, 20000-60000, and I believe a few others opened inbound - nothing being blocked outbound. On the IPCOMMS side of things, I do see the device go REGISTERED - So I know we are at least getting that far.

Any suggestions?


#2

SIP is pretty much SIP, but it depends on how the devices are configured to use SIP, so a comparison of one to another is only telling us that one works, the other apparently not and without the benefit of know how either is configured.

First, is the dialer something you will be using with the same service or was that just for testing?

If not, then disconnect it so that it is not in the way.

Second, do you have a static or public IP?


#3

the softdialer was just a prove that the problem wasnt at the SIP providers end … obviously since i was able to dial out, its not the SIP provider not working.

Yes, it has been de-registered and uninstalled. I am on Frontier Fiber. From the router I go to a 5 port netgear switch. from the switch I go to the phone either via Cat5 cable, or via WIFI. Each reacts the same… I do not have a static ip from Frontier - though that should make no difference…


#4

Yes, having a dynamic IP does indeed make a difference.
You would be better off with a wired connection, so use the cable instead of WiFi.
So, here we go =-

  1. In the router, insure that any SIP ALG or Helper is disabled.
  2. In the router set a DHCP reservation for the phone, so that it will always get assigned the same private IP.
  3. In the router forward ports 5060UDP and 5004UDP (assumes no video as ipcomms does not supoprt) or look in the phone WEB GUI and find and duplicate the “LOCAL RTP” port setting seen in the phone into the router forward rule.
  4. In the phone GUI, look in the network settings and set the NAT Traversal to STUN. (this detects the public IP when using a dynamic public IP and allows the phone to configure the messaging so the provider will know how to contact the phone should and when the IP change).
  5. In the account settings on the phone, look for SIP settings, security and enable accept from SIP proxy only.
  6. In the same SIP settings area (not security), look for keep-alive and set to options with a keep alive of 30 seconds. This is really not needed if forwarding and may be disabled later if the phone continues to function following the setting being disabled. For now, enable it.
  7. In the same SIP settings look for “rport” and if enabled, disable it.
  8. In the phone, set the usable codecs to PCMU/g711u (same things) and g729 and delete the rest from the list so they are in the available listing.
  9. In the phone, set the DNS type to SRV for the account as that is what ipcomms reportedly uses.

I should point out that some Frontier routers do not have a SIP ALG setting and may therefor not be compatible as they will re-write the packets causing issues. If yours does have such a setting, then it will likely be in the firewall, ALG pass-though area.

Try the above and see if that helps. Not knowing what changes may have been made in the past, it may be advisable to factory reset the phone to avoid any conflicts.


#5

Thanks for the reply. I have a reserved DHCP address, so it will never change. Several things you mentioned look familiar but who knows if I did them all at the same time :)… and yes, I believe you are right about the ALG setting not being there as I believe I saw someone else complaining about Frontier wanting to corner the VOIP market on their network.

Will report back. The phone was brand new when I got it but it certainly couldnt hurt to do a hard reset.

Thank you again.


#6

Kicking the frontier 1700 to the curb since it cannot disable SIP-ALG… Bought a dlink nighthawk that can and has gotten good VOIP use ratings… Thanks for all of your help!


#7

Glad it is working, I am marking as solved and closing.


#8