GSWave Registration/Reliability Issues


Good morning-

We are having registration/reliability issues with the GSWave app on both the iOS platform and the Android platform. The app works perfectly and stays registered when it is actively being used but for some reason after a long period of inactivity, the app loses registration.

If we open the app after a long period of inactivity and quickly go to Settings > Accounts, I can see a red dot next to the active account indicating that it’s not registered, but then it will turn green indicating registration within about 5 seconds of me doing this. It’s almost as if the app is force closing in the background somehow. This type of activity happens whether we are on WiFi or using the LTE network.

I’ve got the GSWave account set to use TCP and I have lowered the registration period to 2 minutes. Additionally on my iPhone, I’ve gone to Settings > GSWave and ensured that Background App Refresh is enabled. Additionally Keep-Alive is enabled under the NAT Traversal settings within GSWave as well.

What other settings can I toggle to ensure SIP registration even during periods of inactivity to make this softphone a reliable solution?

Thank you!


you have to go to the mobile phone’s standby settings (usually inside “battery”) and deactivate GSWAve from power saving


So I’ve got an iPhone X and under Settings > Battery, it just gives battery statistics regarding which applications are using the majority of your battery life… there isn’t any way to turn off battery saving on a particular application.

The only option selectable here is to disable low power mode completely, which is already turned off. Am I missing something?


I was referring to Android, on IOS I couldn’t tell you


This is pretty disappointing… I even have a ticket into the Grandstream helpdesk and they can’t offer up a solution either. I’ve personally been fighting this issue now for over 6 months with no solution. I think the problem is pretty obvious… the application is being force closed by the phone (both iOS and Android) after a period of inactivity but nobody seems to have a clear answer as to how to fix this.

What’s even more strange is how this problem isn’t brought up by more people using it… Is nobody else having this issue?

If a softphone app force closes after a period of inactivity and you miss incoming phone calls then it completely defeats the purpose of having a softphone app to begin with.

Thank you for suggestion damiano70… my reply wasn’t meant as an attack to you personally… I’m just very frustrated with this situation and the fact that I can’t even get a clear answer to this from Grandstream themselves.

We are a small hosted PBX company and have personally lost at least 5 customers due to the unreliability of this application and it sure would be nice to come to a solution.


the problem you don’t have to look for it on GS but on your mobile phone, unfortunately there are 1,000 models and a lot of ways to work, unfortunately the app kill function in use is a way to make your mobile phone better manage the memory, there are users who open 30 apps at the same time then they say “the phone is slow”. Of course…
So you need to do a search on how to prevent your mobile phone model from somehow so don’t knock down the app in question, so when your phone goes into standby the app won’t be finished, there should also be a way to extend the timeout before standby.
Good job.
Don’t worry, there are often misunderstandings for “a mistranslated text phrase”. :slight_smile: